summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild')
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
index fb9696112136..47fe1ceaf026 100644
--- a/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+# The package uses distutils
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
@@ -17,7 +19,6 @@ IUSE="test"
RESTRICT="!test? ( test )"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )
"