summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/torrentinfo')
-rw-r--r--net-p2p/torrentinfo/files/torrentinfo-1.8.6-remove-nose.patch38
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6-r3.ebuild26
2 files changed, 64 insertions, 0 deletions
diff --git a/net-p2p/torrentinfo/files/torrentinfo-1.8.6-remove-nose.patch b/net-p2p/torrentinfo/files/torrentinfo-1.8.6-remove-nose.patch
new file mode 100644
index 000000000000..260b5c494321
--- /dev/null
+++ b/net-p2p/torrentinfo/files/torrentinfo-1.8.6-remove-nose.patch
@@ -0,0 +1,38 @@
+From ce97e73493bded33bf83934bd7affd49aff58379 Mon Sep 17 00:00:00 2001
+From: Louis Sautier <sautier.louis@gmail.com>
+Date: Sat, 5 Nov 2022 02:54:34 +0100
+Subject: [PATCH] Remove dependency on nose, fixes #17
+
+Also rename the test file so that it uses a standard name that pytest
+autodetects.
+---
+ test/{tests.py => test_torrentinfo.py} | 5 -----
+ 1 file changed, 5 deletions(-)
+ rename test/{tests.py => test_torrentinfo.py} (99%)
+ mode change 100755 => 100644
+
+diff --git a/test/tests.py b/test/test_torrentinfo.py
+old mode 100755
+new mode 100644
+similarity index 99%
+rename from test/tests.py
+rename to test/test_torrentinfo.py
+index 9e67c9c..ba9bbc7
+--- a/test/tests.py
++++ b/test/test_torrentinfo.py
+@@ -27,7 +27,6 @@
+ from io import StringIO
+
+ import unittest
+-import nose
+ import re
+ import torrentinfo
+
+@@ -704,7 +703,3 @@ def test_is_printable_ascii_success(self):
+ test_string = 'perfectly printable ascii'
+ torrentinfo.dump(test_string, self.config, 0, newline=False)
+ self.assertEqual(self.out.getvalue(), test_string)
+-
+-
+-if __name__ == '__main__':
+- nose.main(buffer=True)
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6-r3.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6-r3.ebuild
new file mode 100644
index 000000000000..877569c19445
--- /dev/null
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6-r3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A torrent file parser"
+HOMEPAGE="https://github.com/Fuuzetsu/torrentinfo"
+SRC_URI="https://github.com/Fuuzetsu/torrentinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ # https://github.com/Fuuzetsu/torrentinfo/pull/16
+ "${FILESDIR}/${P}-fix-tests.patch"
+ # https://github.com/Fuuzetsu/torrentinfo/pull/18
+ "${FILESDIR}/${P}-remove-nose.patch"
+)
+
+distutils_enable_tests pytest