summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/go-ethereum/Manifest1
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.4.16.ebuild29
-rw-r--r--net-p2p/go-ethereum/metadata.xml15
3 files changed, 45 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
new file mode 100644
index 000000000000..f84a2b0bf760
--- /dev/null
+++ b/net-p2p/go-ethereum/Manifest
@@ -0,0 +1 @@
+DIST go-ethereum-1.4.16.tar.gz 14755287 SHA256 8b63fbfb54c256a0f302d9823f8bdb6e8c6a9f6583047d492fc1d7e18c850769 SHA512 ffe97a36c98460405014f6f6f3709ec4fd0556fd9f8f319f120065b2f44b4bc80791143b8a960dc44f858b7f368cd630d3d38ba954402486d67193c76f2eb13f WHIRLPOOL 0bc39515a539116ad963f4d06def628b59199e09aaef17e0420eb649dbbd83395633371d5a2876db2e2a73b906c7d091de83e2a135cf9850d293c5d81624b7ec
diff --git a/net-p2p/go-ethereum/go-ethereum-1.4.16.ebuild b/net-p2p/go-ethereum/go-ethereum-1.4.16.ebuild
new file mode 100644
index 000000000000..365b89db42b9
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.4.16.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="evm"
+
+DEPEND="dev-lang/go"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake geth
+ use evm && emake evm
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+ use evm && dobin build/bin/evm
+}
diff --git a/net-p2p/go-ethereum/metadata.xml b/net-p2p/go-ethereum/metadata.xml
new file mode 100644
index 000000000000..d54331023213
--- /dev/null
+++ b/net-p2p/go-ethereum/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mathy@vanvoorden.be</email>
+ <name>Mathy Vanvoorden</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="evm">Build Ethereum Virtual Machine (EVM)</flag>
+ </use>
+</pkgmetadata>