summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin-core/bitcoin-core-25.1.ebuild10
-rw-r--r--net-p2p/bitcoin-core/metadata.xml5
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-25.1.ebuild2
3 files changed, 9 insertions, 8 deletions
diff --git a/net-p2p/bitcoin-core/bitcoin-core-25.1.ebuild b/net-p2p/bitcoin-core/bitcoin-core-25.1.ebuild
index 7697985bd4d0..351ec614e96f 100644
--- a/net-p2p/bitcoin-core/bitcoin-core-25.1.ebuild
+++ b/net-p2p/bitcoin-core/bitcoin-core-25.1.ebuild
@@ -16,7 +16,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
# IUSE="+cli" doesn't work due to https://bugs.gentoo.org/831045#c3
-IUSE="+asm +berkdb +bitcoin-cli +daemon dbus examples +external-signer kde libs +man nat-pmp +qrcode gui +sqlite system-leveldb +system-libsecp256k1 systemtap test upnp zeromq"
+IUSE="+asm +berkdb +bitcoin-cli +daemon dbus examples +external-signer gui kde libs +man nat-pmp +qrcode +sqlite system-leveldb +system-libsecp256k1 systemtap test upnp zeromq"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -39,9 +39,6 @@ RDEPEND="
acct-group/bitcoin
acct-user/bitcoin
)
- libs? ( !<net-libs/libbitcoinconsensus-25.0 )
- nat-pmp? ( >=net-libs/libnatpmp-20220705:= )
- qrcode? ( >=media-gfx/qrencode-4.1.1:= )
gui? (
!<net-p2p/bitcoin-qt-25.0
>=dev-qt/qtcore-5.15.5:5
@@ -50,6 +47,9 @@ RDEPEND="
>=dev-qt/qtwidgets-5.15.5:5
dbus? ( >=dev-qt/qtdbus-5.15.5:5 )
)
+ libs? ( !<net-libs/libbitcoinconsensus-25.0 )
+ nat-pmp? ( >=net-libs/libnatpmp-20220705:= )
+ qrcode? ( >=media-gfx/qrencode-4.1.1:= )
sqlite? ( >=dev-db/sqlite-3.38.5:= )
system-leveldb? ( virtual/bitcoin-leveldb )
system-libsecp256k1? ( >=dev-libs/libsecp256k1-0.3.1:=[recovery,schnorr] )
@@ -146,7 +146,7 @@ src_configure() {
--disable-util-util
$(use_with libs)
$(use_with daemon)
- $(use_with gui)
+ $(use_with gui gui qt5)
$(use_with dbus qtdbus)
$(use_with system-leveldb)
$(use_with system-libsecp256k1)
diff --git a/net-p2p/bitcoin-core/metadata.xml b/net-p2p/bitcoin-core/metadata.xml
index c5c7717fa5e5..6e6d7e4563b0 100644
--- a/net-p2p/bitcoin-core/metadata.xml
+++ b/net-p2p/bitcoin-core/metadata.xml
@@ -15,12 +15,13 @@
<flag name="bitcoin-cli">Build and install bitcoin-cli command line interface</flag>
<flag name="daemon">Build and install bitcoind daemon</flag>
<flag name="external-signer">Include support for external wallet signer programs</flag>
+ <flag name="gui">Build and install Bitcoin-Qt GUI</flag>
<flag name="libs">Build and install libbitcoinconsensus</flag>
<flag name="nat-pmp">Enable NAT-PMP port forwarding</flag>
<flag name="qrcode">Enable generation of QR Codes for receiving payments</flag>
<flag name="sqlite">Support descriptor wallets in SQLite format</flag>
- <flag name="system-leveldb">Link with virtual/bitcoin-leveldb rather than embedding an internal copy</flag>
- <flag name="system-libsecp256k1">Link with dev-libs/libsecp256k1 rather than embedding an internal copy</flag>
+ <flag name="system-leveldb">Link with <pkg>virtual/bitcoin-leveldb</pkg> rather than embedding an internal copy</flag>
+ <flag name="system-libsecp256k1">Link with <pkg>dev-libs/libsecp256k1</pkg> rather than embedding an internal copy</flag>
<flag name="systemtap">Enable SystemTAP/DTrace tracing</flag>
<flag name="upnp">Enable Universal Plug and Play</flag>
<flag name="zeromq">Report blocks and transactions via zeromq</flag>
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-25.1.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-25.1.ebuild
index ac87d00b9779..2bb59f6223f9 100644
--- a/net-p2p/bitcoin-qt/bitcoin-qt-25.1.ebuild
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-25.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-DESCRIPTION="Transitional package for net-p2p/bitcoin-core[qt5]"
+DESCRIPTION="Transitional package for net-p2p/bitcoin-core[gui]"
HOMEPAGE="https://bitcoincore.org/"
LICENSE="MIT"