summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/mtink/files')
-rw-r--r--net-print/mtink/files/mtink-1.0.16-flags.patch5
-rw-r--r--net-print/mtink/files/mtink-1.0.16-fno-common.patch20
-rw-r--r--net-print/mtink/files/mtink-1.0.16-motif.patch49
-rw-r--r--net-print/mtink/files/mtink-1.0.16-overflow.patch4
4 files changed, 73 insertions, 5 deletions
diff --git a/net-print/mtink/files/mtink-1.0.16-flags.patch b/net-print/mtink/files/mtink-1.0.16-flags.patch
index bee6c339e3f8..f1c4fe680247 100644
--- a/net-print/mtink/files/mtink-1.0.16-flags.patch
+++ b/net-print/mtink/files/mtink-1.0.16-flags.patch
@@ -1,6 +1,5 @@
-diff -ruN mtink-1.0.16.orig/Makefile.ORG mtink-1.0.16/Makefile.ORG
---- mtink-1.0.16.orig/Makefile.ORG 2007-08-28 12:52:30.000000000 +0200
-+++ mtink-1.0.16/Makefile.ORG 2017-01-29 18:09:40.550182789 +0100
+--- a/Makefile.ORG
++++ b/Makefile.ORG
@@ -4,7 +4,7 @@
setUid=1
gimpVersion=
diff --git a/net-print/mtink/files/mtink-1.0.16-fno-common.patch b/net-print/mtink/files/mtink-1.0.16-fno-common.patch
new file mode 100644
index 000000000000..289e2af1517c
--- /dev/null
+++ b/net-print/mtink/files/mtink-1.0.16-fno-common.patch
@@ -0,0 +1,20 @@
+https://sources.debian.org/patches/mtink/1.0.16-11/gcc-10/
+Author: Graham Inggs <ginggs@debian.org>
+--- a/mainSrc/mtink.h
++++ b/mainSrc/mtink.h
+@@ -133,11 +133,11 @@
+
+ #endif
+
+-wConfig_data_t firstConfig;
+-wConfig_data_t newPrinter;
++extern wConfig_data_t firstConfig;
++extern wConfig_data_t newPrinter;
+
+-wConfig_data_t exchangeCartridge;
+-wConfig_data_t alignHead;
++extern wConfig_data_t exchangeCartridge;
++extern wConfig_data_t alignHead;
+
+ #if WITH_X
+ extern Widget createNoPrinterBox(char *);
diff --git a/net-print/mtink/files/mtink-1.0.16-motif.patch b/net-print/mtink/files/mtink-1.0.16-motif.patch
new file mode 100644
index 000000000000..ac66c450b056
--- /dev/null
+++ b/net-print/mtink/files/mtink-1.0.16-motif.patch
@@ -0,0 +1,49 @@
+https://sources.debian.org/patches/mtink/1.0.16-11/lesstif-multiarch/
+--- a/Configure
++++ b/Configure
+@@ -127,6 +127,8 @@
+ /usr/openwin/lib
+ /usr/local/lib
+ /usr/dt/lib'
++LIBDIRS="$LIBDIRS `${CC-gcc} -print-search-dirs 2>/dev/null |
++ awk '/^libraries:/{print $2}' | tr ':' ' '`"
+
+ # Add gimp-2.0 for fedora core 2
+ INCLDIRS='/usr/include/gimp-2.0/libgimp
+@@ -279,11 +281,6 @@
+ exit 1
+ fi
+
+- case $OS in
+- Linux) . ./checkMotifVersion.sh;;
+- Darwin) . ./checkMotifVersion.sh;;
+- esac
+-
+ if [ "$MotifLib" != "" ]
+ then
+ mlCmd="s@^MOLIB.*@MOLIB = $MotifLib@"
+@@ -297,24 +294,6 @@
+ miCmd=
+ fi
+
+- # Check for the Xp libary, some Motif libraries need this
+-
+- xplibFound=0
+- for dir in $LIBDIRS
+- do
+- if [ "`ls -c $dir/libXp.* 2>/dev/null`" != "" ]
+- then
+- xplibFound=1
+- break
+- fi
+- done
+-
+- # but not for Solaris
+- if [ `uname` = SunOS ]
+- then
+- xplibFound=0
+- fi
+-
+ # Gimp part ################################################
+ # check for gimp
+ includeFileFound=0
diff --git a/net-print/mtink/files/mtink-1.0.16-overflow.patch b/net-print/mtink/files/mtink-1.0.16-overflow.patch
index d57e2cd0139e..b0858485293e 100644
--- a/net-print/mtink/files/mtink-1.0.16-overflow.patch
+++ b/net-print/mtink/files/mtink-1.0.16-overflow.patch
@@ -1,5 +1,5 @@
---- a/server/mtinkd.c 2012-01-15 13:03:41.000000000 +0000
-+++ b/server/mtinkd.c 2012-01-15 13:03:58.000000000 +0000
+--- a/server/mtinkd.c
++++ b/server/mtinkd.c
@@ -244,7 +244,7 @@
/* look for pid into /var/run/mtink(<fifo> */
if ( (fp = fopen(runFile,"r")) )