summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip-plugin/Manifest1
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.22.4.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 115ec594bdd8..e1a74f1a0c27 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1 +1,2 @@
DIST hplip-3.22.2-plugin.run 11487296 BLAKE2B 2c953e85b3ef299066aaf158121f4a3db68b00f2e2df3cb35acc78a54a466e8a3e204592fbfa2128acb87c0f9b258178cd29faf4e93600ee4b10fe81b93f213b SHA512 5efa533863bec3e7e5fc354411216e6e4232c2bbc15a062ff829296e1357c523333df8221a341b10c940022708299a33449020e633a9873205b568959327cb24
+DIST hplip-3.22.4-plugin.run 11487215 BLAKE2B dc9b0977c35bff29c81f3854e7104301c3bd96cf77833a056a09dd2b2465e8f47c53c941ff4d1235f62eae9a3af93fe95129111d7abf5e82032959de1167920e SHA512 be53ad8d2f910d772535775037b912f332122a6aa141fa2f92415dd9a259efca34011939e648fc7a46e8123ee409396b28236947e37539153c55f80c6d7f8cd1
diff --git a/net-print/hplip-plugin/hplip-plugin-3.22.4.ebuild b/net-print/hplip-plugin/hplip-plugin-3.22.4.ebuild
new file mode 100644
index 000000000000..54c789992915
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.22.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+S="${WORKDIR}"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="orblite"
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+src_install() {
+ local hplip_arch plugin
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}