summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/haproxy-dataplaneapi')
-rw-r--r--net-proxy/haproxy-dataplaneapi/Manifest2
-rw-r--r--net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.8.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/net-proxy/haproxy-dataplaneapi/Manifest b/net-proxy/haproxy-dataplaneapi/Manifest
index 43d8f9d6bd57..b299bdc2f602 100644
--- a/net-proxy/haproxy-dataplaneapi/Manifest
+++ b/net-proxy/haproxy-dataplaneapi/Manifest
@@ -2,3 +2,5 @@ DIST haproxy-dataplaneapi-2.5.1-deps.tar.xz 42850336 BLAKE2B 76cc7fedcfaf4f45383
DIST haproxy-dataplaneapi-2.5.1.tar.gz 558942 BLAKE2B cae018e048ac6585d3518b114c96df69e31d335a5b26ea2b474a6c3172b1f37014d45046543b2d088921e2a160915b5abb8a0a07ea7578f1430147c8b3672f12 SHA512 36b7f850ae89a4f65d5c8a8d50d38e6190ecd1f9c42f7f91997305b87a08fa20a816fd2e5cba18b2408a3760846f2d6d79fdbc8119fa2efcd4c9958324bde2f4
DIST haproxy-dataplaneapi-2.7.5-vendor.tar.xz 24803428 BLAKE2B 7f5e1a5de53eb4477d3c5ec88d9b20eeab99ecaa42d49d450699af67ae31b9021bf8244244c94d994169ec65093e5f7bfdb109d4919aa0e5ae0f206f36ef1d51 SHA512 3d56f703a679ec7c750cf8597c53bd092ec254d05c8dee9f9413f6ac5987b64620392a122193ee248c2db4de8b4e63bd9ec6880342e2c3fca87770340635e1de
DIST haproxy-dataplaneapi-2.7.5.tar.gz 741786 BLAKE2B 9632d1465c8619f4b363fc060fd7c09677f807cb00923618a2a568e9e5cd5f4887de0f6fb31ca79514c5784fa72b897418c2e87fa0aa5a168c3a3455547c9589 SHA512 13bb8565888dd45ac8441c082c02889c6068a51613e93d0c638474b3eb076b58af49ad44813dc30c3b9ed2f55da6ada34d39451070d54ae2858dc219b20a4007
+DIST haproxy-dataplaneapi-2.8.0-vendor.tar.xz 2346260 BLAKE2B 9c8dbd3de567bb910bc52bc1cf008cb36326cbc40f79108acc1d984d45ed8f34fa7179b4e1d8d7917f1a13da847b1d4f249e4b64a57361a5cd3c6287b6050199 SHA512 0742aae5270a150239654b94d0a8ff226a47932825dfd908c9a531a5f6a9d8d5263761cc83f1dcc206bcae39fba498f80a66a1e6f2df501695ca38e75961200f
+DIST haproxy-dataplaneapi-2.8.0.tar.gz 739904 BLAKE2B 1e1c1b504f070489808a101fafabcc499e1ba1369b08a9cf1b930f6adc8a315506225ba7535d626cbec9fc6483e4ae262e49809557a80b7e7aa712e37da01b4e SHA512 601eb1c1d37525a1e406c9eb99e933bb785ac2ffe430f9e53cb5c551695856283cd42aef16ff239e6525eec686c09582e05f2ddea8c63bda2fcf1a86610ea027
diff --git a/net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.8.0.ebuild b/net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.8.0.ebuild
new file mode 100644
index 000000000000..7f31a72b4a64
--- /dev/null
+++ b/net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="haproxy dataplane api / sidecar"
+HOMEPAGE="https://github.com/haproxytech/dataplaneapi https://www.haproxy.com/documentation/dataplaneapi/latest/"
+
+SRC_URI="https://github.com/haproxytech/dataplaneapi/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ http://gentooexperimental.org/~patrick/${P}-vendor.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/dataplaneapi-${PV}"
+
+src_compile() {
+ ego build -o ./build/dataplaneapi ./cmd/dataplaneapi/
+}
+
+src_install() {
+ dobin build/dataplaneapi
+ dodoc README.md
+}