summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/pingtunnel')
-rw-r--r--net-proxy/pingtunnel/Manifest1
-rw-r--r--net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch60
-rw-r--r--net-proxy/pingtunnel/metadata.xml9
-rw-r--r--net-proxy/pingtunnel/pingtunnel-0.72.ebuild38
4 files changed, 108 insertions, 0 deletions
diff --git a/net-proxy/pingtunnel/Manifest b/net-proxy/pingtunnel/Manifest
new file mode 100644
index 000000000000..13d05868ebfd
--- /dev/null
+++ b/net-proxy/pingtunnel/Manifest
@@ -0,0 +1 @@
+DIST PingTunnel-0.72.tar.gz 64188 SHA256 b318f7aa7d88918b6269d054a7e26f04f97d8870f47bd49a76cb2c99c73407a4 SHA512 943fc571ca95bb6af59f2a74458470865a89a502145bb1e5cf9b86159d61d897418d10d100691337f299892af7aba65964624462068a77ef1645890a4abf5d17 WHIRLPOOL a39fe5cc57d87b5977fcec53083a405c5310d74ea857af3a3837c0347d78c217a3e8fc911130a93e2ec1ab43f793104185cfeb7277caf6dc7b70b2c0209d0b74
diff --git a/net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch b/net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch
new file mode 100644
index 000000000000..9dce0992cbda
--- /dev/null
+++ b/net-proxy/pingtunnel/files/pingtunnel-0.72_makefile.patch
@@ -0,0 +1,60 @@
+--- Makefile
++++ Makefile
+@@ -2,11 +2,26 @@
+ # (c) 2004-2009 Daniel Stoedle, daniels@cs.uit.no
+ # ptunnel.exe target added by Mike Miller, mike@mikeage.net
+
+-CC = gcc
+-CFLAGS = -Wall -g
+-LDOPTS = -lpthread -lpcap
++# set to 1 to enable debug symbols
++DEBUG=0
++
++# set to 1 to enable selinux support
++SELINUX=0
++
++CC ?= gcc
++CFLAGS += -Wall
++LIBS += -lpthread -lpcap
+ PT_OBJS = ptunnel.o md5.o
+
++ifeq ($(DEBUG),1)
++CFLAGS += -g
++endif
++
++ifeq ($(SELINUX),1)
++CPPFLAGS += -DHAVE_SELINUX
++LIBS += -lselinux
++endif
++
+ WIN32_CC = mingw32-gcc
+ WIN32_CFLAGS = -g -Wall -DWIN32 -I"c:\Program Files\WpdPack\Include"
+ WIN32_LDOPTS = -lwpcap -lwsock32 -L"c:\Program Files\WpdPack\Lib"
+@@ -26,13 +41,13 @@
+
+
+ install: ptunnel
+- install -d $(bindir)/
+- install -d $(mandir)/
+- install ./ptunnel $(bindir)/ptunnel
+- install ./ptunnel.8 $(mandir)/ptunnel.8
++ install -d "$(DESTDIR)/$(bindir)/"
++ install -d "$(DESTDIR)/$(mandir)/"
++ install -m755 ./ptunnel "$(DESTDIR)/$(bindir)/ptunnel"
++ install -m644 ./ptunnel.8 "$(DESTDIR)/$(mandir)/ptunnel.8"
+
+ ptunnel: $(PT_OBJS)
+- $(CC) -o $@ $^ $(LDOPTS) `[ -e /usr/include/selinux/selinux.h ] && echo -lselinux`
++ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+ ptunnel.exe: $(WIN32_PT_OBJS)
+ $(CC) -o $@ $^ $(WIN32_LDOPTS)
+@@ -47,7 +62,7 @@
+ $(CC) $(CFLAGS) -MM *.c > $@
+
+ %.o:%.c
+- $(CC) $(CFLAGS) `[ -e /usr/include/selinux/selinux.h ] && echo -DHAVE_SELINUX` -c -o $@ $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c -o $@ $<
+
+ %.obj:%.c
+ $(WIN32_CC) $(WIN32_CFLAGS) -c -o $@ $<
diff --git a/net-proxy/pingtunnel/metadata.xml b/net-proxy/pingtunnel/metadata.xml
new file mode 100644
index 000000000000..38e901528de8
--- /dev/null
+++ b/net-proxy/pingtunnel/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>bircoph@gentoo.org</email>
+</maintainer>
+<longdescription>Ptunnel is an application that allows you to reliably tunnel TCP connections to a remote host
+using ICMP echo request and reply packets, commonly known as ping requests and replies.</longdescription>
+</pkgmetadata>
diff --git a/net-proxy/pingtunnel/pingtunnel-0.72.ebuild b/net-proxy/pingtunnel/pingtunnel-0.72.ebuild
new file mode 100644
index 000000000000..8e775dc57965
--- /dev/null
+++ b/net-proxy/pingtunnel/pingtunnel-0.72.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tunnel TCP over ICMP"
+HOMEPAGE="http://www.cs.uit.no/~daniels/PingTunnel"
+SRC_URI="http://www.cs.uit.no/~daniels/PingTunnel/PingTunnel-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sh ~x86"
+IUSE="doc selinux"
+
+DEPEND="
+ net-libs/libpcap
+ selinux? ( sys-libs/libselinux )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/PingTunnel
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}_makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake $(usex selinux "SELINUX=1" "SELINUX=0")
+}
+
+src_install() {
+ default
+ use doc && dohtml web/*
+}