summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/privoxy/privoxy-3.0.24.ebuild')
-rw-r--r--net-proxy/privoxy/privoxy-3.0.24.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-proxy/privoxy/privoxy-3.0.24.ebuild b/net-proxy/privoxy/privoxy-3.0.24.ebuild
index 3bbb1189810b..0f824fab10d2 100644
--- a/net-proxy/privoxy/privoxy-3.0.24.ebuild
+++ b/net-proxy/privoxy/privoxy-3.0.24.ebuild
@@ -30,6 +30,15 @@ REQUIRED_USE="toggle? ( editor )"
S="${WORKDIR}/${P%_*}-${PRIVOXY_STATUS}"
+pkg_pretend() {
+ if ! use threads; then
+ ewarn
+ ewarn "Privoxy may be very slow without threads support, consider to enable them."
+ ewarn "See also http://www.privoxy.org/faq/trouble.html#GENTOO-RICERS"
+ ewarn
+ fi
+}
+
pkg_setup() {
enewgroup privoxy
enewuser privoxy -1 -1 /etc/privoxy privoxy
@@ -43,7 +52,6 @@ src_prepare() {
}
src_configure() {
-
econf \
$(use_enable acl acl-support) \
$(use_enable editor) \