summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/squid/files')
-rw-r--r--net-proxy/squid/files/squid-4.17-fix-libxml2-2.10.0.patch30
-rw-r--r--net-proxy/squid/files/squid-4.3-gentoo.patch79
2 files changed, 0 insertions, 109 deletions
diff --git a/net-proxy/squid/files/squid-4.17-fix-libxml2-2.10.0.patch b/net-proxy/squid/files/squid-4.17-fix-libxml2-2.10.0.patch
deleted file mode 100644
index ebc0cd698e14..000000000000
--- a/net-proxy/squid/files/squid-4.17-fix-libxml2-2.10.0.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-https://bugs.gentoo.org/866518
-https://github.com/squid-cache/squid/commit/c4e6b7c2a12fa218089fe839f769ffc8ae18dea4
-
-From c4e6b7c2a12fa218089fe839f769ffc8ae18dea4 Mon Sep 17 00:00:00 2001
-From: Nick Wellnhofer <wellnhofer@aevum.de>
-Date: Sun, 20 Feb 2022 19:42:40 +0000
-Subject: [PATCH] ESI: Drop incorrect and unnecessary xmlSetFeature() call
- (#988)
-
-xmlSetFeature() has been deprecated for 10+ years and will eventually be
-removed from libxml2. Squid calls xmlSetFeature() with the wrong
-argument: a nil `value` pointer instead of a pointer to a zero value.
-When called with a nil `value`, the function does nothing but returning
-an error. Squid does not check whether xmlSetFeature() call is
-successful, and the bug went unnoticed since libxml2 support was added
-in commit 964b44c.
-
-Since libxml2 does not substitute entities by default, the call can be
-removed to achieve the intended effect.
---- a/src/esi/Libxml2Parser.cc
-+++ b/src/esi/Libxml2Parser.cc
-@@ -118,7 +118,6 @@ ESILibxml2Parser::ESILibxml2Parser(ESIParserClient *aClient) : theClient (aClien
-
- /* TODO: grab the document encoding from the headers */
- parser = xmlCreatePushParserCtxt(&sax, static_cast<void *>(this), NULL, 0, NULL);
-- xmlSetFeature(parser, "substitute entities", 0);
-
- if (entity_doc == NULL)
- entity_doc = htmlNewDoc(NULL, NULL);
-
diff --git a/net-proxy/squid/files/squid-4.3-gentoo.patch b/net-proxy/squid/files/squid-4.3-gentoo.patch
deleted file mode 100644
index f5152b898852..000000000000
--- a/net-proxy/squid/files/squid-4.3-gentoo.patch
+++ /dev/null
@@ -1,79 +0,0 @@
---- a/configure.ac 2018-10-14 17:22:35.000000000 +0300
-+++ b/configure.ac 2018-10-17 21:27:24.806986467 +0300
-@@ -32,9 +32,9 @@ PRESET_CXXFLAGS="$CXXFLAGS"
- PRESET_LDFLAGS="$LDFLAGS"
-
- dnl Set default LDFLAGS
--if test "x$LDFLAGS" = "x" ; then
-- LDFLAGS="-g"
--fi
-+dnl if test "x$LDFLAGS" = "x" ; then
-+dnl LDFLAGS="-g"
-+dnl fi
-
- # Check for GNU cc
- AC_PROG_CC
---- a/src/cf.data.pre 2018-10-14 08:25:34.000000000 +0300
-+++ b/src/cf.data.pre 2018-10-17 21:27:24.809986705 +0300
-@@ -1520,6 +1520,7 @@ acl Safe_ports port 280 # http-mgmt
- acl Safe_ports port 488 # gss-http
- acl Safe_ports port 591 # filemaker
- acl Safe_ports port 777 # multiling http
-+acl Safe_ports port 901 # SWAT
- acl CONNECT method CONNECT
- NOCOMMENT_END
- DOC_END
-@@ -6819,11 +6820,11 @@ COMMENT_END
-
- NAME: cache_mgr
- TYPE: string
--DEFAULT: webmaster
-+DEFAULT: root
- LOC: Config.adminEmail
- DOC_START
- Email-address of local cache manager who will receive
-- mail if the cache dies. The default is "webmaster".
-+ mail if the cache dies. The default is "root".
- DOC_END
-
- NAME: mail_from
---- a/src/debug.cc 2018-10-14 08:25:34.000000000 +0300
-+++ b/src/debug.cc 2018-10-17 21:27:24.807986546 +0300
-@@ -490,7 +490,7 @@ _db_init(const char *logfile, const char
- #if HAVE_SYSLOG && defined(LOG_LOCAL4)
-
- if (Debug::log_syslog)
-- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, syslog_facility);
-+ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, syslog_facility);
-
- #endif /* HAVE_SYSLOG */
-
---- a/src/main.cc 2018-10-14 08:25:34.000000000 +0300
-+++ b/src/main.cc 2018-10-17 21:28:28.632044541 +0300
-@@ -1912,7 +1912,7 @@ watch_child(const CommandLine &masterCom
-
- enter_suid();
-
-- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
-+ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, LOG_LOCAL4);
-
- if (!opt_foreground)
- GoIntoBackground();
-@@ -2012,7 +2012,7 @@ watch_child(const CommandLine &masterCom
-
- if ((pid = fork()) == 0) {
- /* child */
-- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
-+ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, LOG_LOCAL4);
- (void)execvp(masterCommand.arg0(), kidCommand.argv());
- int xerrno = errno;
- syslog(LOG_ALERT, "execvp failed: %s", xstrerr(xerrno));
-@@ -2024,7 +2024,7 @@ watch_child(const CommandLine &masterCom
- }
-
- /* parent */
-- openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
-+ openlog(APP_SHORTNAME, LOG_PID | LOG_NDELAY, LOG_LOCAL4);
-
- // If Squid received a signal while checking for dying kids (below) or
- // starting new kids (above), then do a fast check for a new dying kid