summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/c-icap/Manifest1
-rw-r--r--net-proxy/c-icap/c-icap-0.2.6.ebuild112
-rw-r--r--net-proxy/c-icap/files/c-icap-0.2.6-fix-icap-parsing.patch11
-rw-r--r--net-proxy/c-icap/files/c-icap.conf11
-rw-r--r--net-proxy/c-icap/files/c-icap.init.326
-rw-r--r--net-proxy/c-icap/files/c-icap.logrotate13
-rw-r--r--net-proxy/c-icap/metadata.xml7
7 files changed, 0 insertions, 181 deletions
diff --git a/net-proxy/c-icap/Manifest b/net-proxy/c-icap/Manifest
deleted file mode 100644
index edc5a7ec0b2e..000000000000
--- a/net-proxy/c-icap/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST c_icap-0.2.6.tar.gz 581856 BLAKE2B ce1e83efd9f7d1a9e78fd1cd4dd60e2323b2e35ff44bbfd93484524ecd37f0a7d1031042527ca0dd9804fb44e1033063237ad3b4e516d1ef956a13cee45a633c SHA512 3b1fe1f89581ec4649f74771f4a33a08637428f6cf81a9228f5d08405207c3495e6dadd590254dd6804ccbb7c34af1fc62973563c6156c4249941a599a072a40
diff --git a/net-proxy/c-icap/c-icap-0.2.6.ebuild b/net-proxy/c-icap/c-icap-0.2.6.ebuild
deleted file mode 100644
index cd9886df7296..000000000000
--- a/net-proxy/c-icap/c-icap-0.2.6.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils multilib flag-o-matic
-
-MY_PN="${PN/-/_}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="C Implementation of an ICAP server"
-HOMEPAGE="http://c-icap.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="berkdb ipv6 ldap"
-
-RDEPEND="berkdb? ( sys-libs/db )
- ldap? ( net-nds/openldap )
- sys-libs/zlib"
-
-DEPEND="${RDEPEND}"
-RDEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}"/c-icap-0.2.6-fix-icap-parsing.patch
-}
-
-src_configure() {
- # some void *** pointers get casted around and can be troublesome to
- # fix properly.
- append-flags -fno-strict-aliasing
-
- econf \
- --sysconfdir=/etc/${PN} \
- --disable-dependency-tracking \
- --disable-maintainer-mode \
- --disable-static \
- --enable-large-files \
- $(use_enable ipv6) \
- $(use_with berkdb bdb) \
- $(use_with ldap)
-}
-
-src_compile() {
- emake LOGDIR="/var/log"
-}
-
-src_install() {
- emake \
- LOGDIR="/var/log" \
- DESTDIR="${D}" install
-
- find "${D}" -name '*.la' -delete || die
-
- # Move the daemon out of the way
- dodir /usr/libexec
- mv "${D}"/usr/bin/c-icap "${D}"/usr/libexec || die
-
- # Remove the default configuration files since we have etc-update to
- # take care of it for us.
- rm "${D}"/etc/${PN}/c-icap.*.default || die
-
- # Fix the configuration file; for some reason it's a bit messy
- # around.
- sed -i \
- -e 's:/usr/var/:/var/:g' \
- -e 's:/var/log/:/var/log/c-icap/:g' \
- -e 's:/usr/etc/:/etc/c-icap/:g' \
- -e 's:/usr/local/c-icap/etc/:/etc/c-icap/:g' \
- -e 's:/usr/lib/:/usr/'$(get_libdir)'/:g' \
- "${D}"/etc/${PN}/c-icap.conf \
- || die
-
- dodoc AUTHORS README TODO ChangeLog
-
- newinitd "${FILESDIR}/${PN}.init.3" ${PN}
- newconfd "${FILESDIR}/${PN}.conf" ${PN}
- keepdir /var/log/c-icap
-
- insopts -m0644
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/${PN}.logrotate ${PN}
-
- # avoid triggering portage's symlink protection; this is handled by
- # the init script anyway.
- rm -rf "${D}"/var/run
-}
-
-pkg_postinst() {
- elog "To enable Squid to call the ICAP modules from a local server you should set"
- elog "the following in your squid.conf:"
- elog ""
- elog " icap_enable on"
- elog ""
- elog " # not strictly needed, but some modules might make use of these"
- elog " icap_send_client_ip on"
- elog " icap_send_client_username on"
- elog ""
- elog " icap_service service_req reqmod_precache bypass=1 icap://localhost:1344/service"
- elog " adaptation_access service_req allow all"
- elog ""
- elog " icap_service service_resp respmod_precache bypass=0 icap://localhost:1344/service"
- elog " adaptation_access service_resp allow all"
- elog ""
- elog "You obviously will have to replace \"service\" with the actual ICAP service to"
- elog "use."
-}
diff --git a/net-proxy/c-icap/files/c-icap-0.2.6-fix-icap-parsing.patch b/net-proxy/c-icap/files/c-icap-0.2.6-fix-icap-parsing.patch
deleted file mode 100644
index b0275edefee5..000000000000
--- a/net-proxy/c-icap/files/c-icap-0.2.6-fix-icap-parsing.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- c-icap-0.2.2.orig/request.c 2013-02-03 16:37:43.000000000 +0000
-+++ c-icap-02.2/request.c 2012-06-19 12:55:51.000000000 +0000
-@@ -267,7 +267,7 @@
- req->req_server[servnamelen] = '\0';
- if (*end == '/') { /*service */
- start = ++end;
-- while (*end != ' ' && *end != '?')
-+ while (*end && *end != ' ' && *end != '?')
- end++;
- len = end - start;
- if (len > 0) {
diff --git a/net-proxy/c-icap/files/c-icap.conf b/net-proxy/c-icap/files/c-icap.conf
deleted file mode 100644
index d3f2420b2dce..000000000000
--- a/net-proxy/c-icap/files/c-icap.conf
+++ /dev/null
@@ -1,11 +0,0 @@
-# Use this to change the configuration file to use for c-icap.
-configfile=/etc/c-icap/c-icap.conf
-
-# Use this to set any extra option for the daemon. Do not use the -f
-# option here.
-EXTRA_OPTS=""
-
-# If you enabled LDAP support, and you'd like to access tables stored
-# in the local LDAP instance, you want to uncomment the following
-# line.
-#rc_need="slapd"
diff --git a/net-proxy/c-icap/files/c-icap.init.3 b/net-proxy/c-icap/files/c-icap.init.3
deleted file mode 100644
index c11ae50b9f79..000000000000
--- a/net-proxy/c-icap/files/c-icap.init.3
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-: ${configfile:=/etc/c-icap/c-icap.conf}
-
-get_config() {
- local value=$(awk '$1 == "'$1'" { print $2 }' ${configfile})
- echo ${value:-$2}
-}
-
-command="/usr/libexec/c-icap"
-command_arguments="${EXTRA_OPTS} -f ${configfile}"
-pidfile=$(get_config PidFile /var/run/c-icap/c-icap.pid)
-
-depend() {
- need localmount
- config ${configfile}
- [ "$(get_config Logger file_logger)" = "sys_logger" ] && use logger
-}
-
-start_pre() {
- local cmdsocket=$(get_config CommandsSocket /var/run/c-icap/c-icap.ctl)
-
- checkpath -d "$(dirname "${cmdsocket}")" "$(dirname "${pidfile}")"
-}
diff --git a/net-proxy/c-icap/files/c-icap.logrotate b/net-proxy/c-icap/files/c-icap.logrotate
deleted file mode 100644
index c4c0a5d34f6e..000000000000
--- a/net-proxy/c-icap/files/c-icap.logrotate
+++ /dev/null
@@ -1,13 +0,0 @@
-/var/log/c-icap/access.log {
- missingok
- postrotate
- /etc/init.d/c-icap restart
- endscript
-}
-
-/var/log/cicap-server.log {
- missingok
- postrotate
- /etc/init.d/c-icap restart
- endscript
-}
diff --git a/net-proxy/c-icap/metadata.xml b/net-proxy/c-icap/metadata.xml
deleted file mode 100644
index af696825f7a7..000000000000
--- a/net-proxy/c-icap/metadata.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <upstream>
- <remote-id type="sourceforge">c-icap</remote-id>
- </upstream>
-</pkgmetadata>