summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip/captagent/captagent-6.3.1-r1.ebuild')
-rw-r--r--net-voip/captagent/captagent-6.3.1-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-voip/captagent/captagent-6.3.1-r1.ebuild b/net-voip/captagent/captagent-6.3.1-r1.ebuild
new file mode 100644
index 000000000000..3023031778b2
--- /dev/null
+++ b/net-voip/captagent/captagent-6.3.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="100% Open-Source Packet Capture Agent for HEP"
+HOMEPAGE="https://sipcapture.org/ https://github.com/sipcapture/captagent"
+SRC_URI="https://github.com/sipcapture/captagent/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 mysql pcre redis ssl"
+
+PATCHES=(
+ # https://github.com/sipcapture/captagent/pull/239 (merged).
+ "${FILESDIR}/${P}-gcc10.patch"
+ # https://github.com/sipcapture/captagent/pull/245 (merged).
+ "${FILESDIR}/${P}-captagent-6.3.1-r1-clang.patch"
+ # Already upstreamed for next version.
+ "${FILESDIR}/${P}-configure.patch"
+)
+
+DEPEND="dev-libs/json-c
+ net-libs/libpcap
+ dev-libs/libuv
+ mysql? ( dev-db/mysql-connector-c )
+ pcre? ( dev-libs/libpcre )
+ redis? ( dev-db/redis )
+ ssl? ( dev-libs/openssl:= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-compression \
+ --disable-epan \
+ $(use_enable ipv6) \
+ $(use_enable mysql) \
+ $(use_enable pcre) \
+ $(use_enable redis) \
+ $(use_enable ssl tls) \
+ $(use_enable ssl)
+}