summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/riseup-vpn')
-rw-r--r--net-vpn/riseup-vpn/Manifest2
-rw-r--r--net-vpn/riseup-vpn/riseup-vpn-0.21.11_p20230412.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/net-vpn/riseup-vpn/Manifest b/net-vpn/riseup-vpn/Manifest
index e204652a89e5..31d4a840b6bc 100644
--- a/net-vpn/riseup-vpn/Manifest
+++ b/net-vpn/riseup-vpn/Manifest
@@ -2,3 +2,5 @@ DIST riseup-vpn-0.21.11-deps.tar.xz 180372544 BLAKE2B 3679347cb3bc83850b78d42906
DIST riseup-vpn-0.21.11.tar.gz 7595837 BLAKE2B a1cd09741f044d03577128ab88ba6e6d9961a1a39c0e6488d79e73ec9c94b7a0fa44463a07d2e2130fe4adf986d86a693cb3114bae99e4a4bb55d23b90f2c871 SHA512 b4fa6f57f97bfba364c7aa9b2a4fc08561c7753d5471424534884a3279e5ff2bd102cc254c4e15a99f6fa47ef16abf1c691d3d174eda27bbfdac61d192f6fbb1
DIST riseup-vpn-0.21.11_p20221113-deps.tar.xz 1628980 BLAKE2B 5af75fb2cd71da2fd949f89d1c768c001a268cc7fab0d26a621a02136eaddb8466e4cd1346954b785a5ac695bb816dd791b006b226359204670c47d4a47d25b8 SHA512 f0a8a657ac1aeefcf3d83b970157b600247ef228072c93c5aa1dfe062b8a9f81a4e13c44f51dc9c289f2b76de4eff516b045d3a145a905034b5a3ee263dbd68d
DIST riseup-vpn-0.21.11_p20221113.tar.gz 7696220 BLAKE2B ba4c968e7b185c98e8995b300ab25ec79103473cafbd647c262d51308c173ba1a48f69b42b8dad2356791711137688a6a9a3a47e68294579be51ecd77b04bac4 SHA512 44157eebd266b99d146f29f621576c181a012d5965c4172fddb93232230f42f128958342891d8137bdedfb3236f132a1c73a9f45cad803b29d520393eb7d8cb4
+DIST riseup-vpn-0.21.11_p20230412-deps.tar.xz 29805564 BLAKE2B 4105bc0461d542b7f87890a50db26fa96302088070f0477c0f8d0707994efecc8f4bc91b5316e1834f98f9890793eea9df9041de78af6785f68e480c0d384124 SHA512 f8a3bd099a1e3733577de892a4939a223f851e949275afea8f5a77b38a529dbf7b9b161bbb4e1518530e97027c612ae352895a79275d287c31cb41ab2477aaca
+DIST riseup-vpn-0.21.11_p20230412.tar.gz 7701340 BLAKE2B 42564c1a3a3401c909f41e2db3f232ed06617630a4f96a28a3d946e6e3c53337cde8401e8a89b0e83824cfb4fe8a670f4aec03eb09cc6c9b1b4e94111e0a04ff SHA512 966b64a8071ebe56d1ec8b43b36c7b168600b445ca6039fa7fc6696329e8eb825c0d3f20e4ff509128acf1b962676eb4dfea5aa6890afc394a0aa218799eb61d
diff --git a/net-vpn/riseup-vpn/riseup-vpn-0.21.11_p20230412.ebuild b/net-vpn/riseup-vpn/riseup-vpn-0.21.11_p20230412.ebuild
new file mode 100644
index 000000000000..a98d4dc91b7a
--- /dev/null
+++ b/net-vpn/riseup-vpn/riseup-vpn-0.21.11_p20230412.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit desktop python-single-r1 go-module qmake-utils virtualx xdg
+
+COMMIT="ec3f27147f2f72cebedf12ae0cc40277b78e998e"
+
+DESCRIPTION="Anonymous encrypted VPN client powered by Bitmask"
+HOMEPAGE="https://riseup.net/en/vpn https://0xacab.org/leap/bitmask-vpn https://bitmask.net"
+SRC_URI="
+ https://0xacab.org/leap/bitmask-vpn/-/archive/${COMMIT}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~andrewammerlaan/${P}-deps.tar.xz
+"
+S="${WORKDIR}/bitmask-vpn-${COMMIT}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="test"
+PROPERTIES="test_network"
+RESTRICT="test"
+# The tests require internet access to connect to Riseup Networks
+
+# Generated with dev-go/golicense
+LICENSE="GPL-3 BSD-2 CC0-1.0 MIT BSD"
+KEYWORDS="~amd64"
+SLOT="0"
+
+BDEPEND="
+ virtual/pkgconfig
+ dev-qt/linguist-tools
+ test? ( dev-qt/qttest:5 )
+"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtquickcontrols2:5[widgets]
+ dev-qt/qtsvg:5
+"
+
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ net-vpn/openvpn
+ sys-auth/polkit
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.21.11_p20221113-revert-data-cipher-arg-to-cipher.patch"
+)
+
+src_prepare() {
+ default
+
+ # do not pre-strip
+ sed -i -e '/strip $RELEASE\/$TARGET/d' gui/build.sh || die
+
+ # We need qmake and lrelease from qt5 bin dir
+ export PATH="${PATH}:$(qt5_get_bindir)" || die
+}
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+ virtx emake test_ui
+}
+
+src_install() {
+ einstalldocs
+
+ dobin "build/qt/release/riseup-vpn"
+
+ python_scriptinto /usr/sbin
+ python_doscript "pkg/pickle/helpers/bitmask-root"
+
+ insinto /usr/share/polkit-1/actions
+ newins "pkg/pickle/helpers/se.leap.bitmask.policy" se.leap.bitmask.riseupvpn.policy
+
+ newicon -s scalable "providers/riseup/assets/icon.svg" riseup.svg
+ make_desktop_entry "${PN}" RiseupVPN riseup Network
+
+ dodoc -r docs/*
+}