summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/crackle/crackle-0.1-r1.ebuild')
-rw-r--r--net-wireless/crackle/crackle-0.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-wireless/crackle/crackle-0.1-r1.ebuild b/net-wireless/crackle/crackle-0.1-r1.ebuild
new file mode 100644
index 000000000000..9bcfc7aa0696
--- /dev/null
+++ b/net-wireless/crackle/crackle-0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Crackle cracks BLE Encryption (AKA Bluetooth Smart)"
+HOMEPAGE="http://lacklustre.net/projects/crackle/"
+SRC_URI="http://lacklustre.net/projects/crackle/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+PATCHES=(
+ ${FILESDIR}"/flags.patch"
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin crackle
+}