summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/gr-scopy/gr-scopy-9999.ebuild')
-rw-r--r--net-wireless/gr-scopy/gr-scopy-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-wireless/gr-scopy/gr-scopy-9999.ebuild b/net-wireless/gr-scopy/gr-scopy-9999.ebuild
new file mode 100644
index 000000000000..f695c1501bb3
--- /dev/null
+++ b/net-wireless/gr-scopy/gr-scopy-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Scopy IIO blocks for GNU Radio"
+HOMEPAGE="https://github.com/analogdevicesinc/gr-scopy"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/analogdevicesinc/gr-scopy.git"
+ inherit git-r3
+else
+ COMMIT="f48b45cabe2a81f491137dbc220032ea65f080c3"
+ SRC_URI="https://github.com/analogdevicesinc/gr-scopy/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ =net-wireless/gnuradio-3.8*:=
+ sci-libs/volk:=
+ "
+DEPEND="${RDEPEND}"
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}