summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/horst/horst-9999.ebuild')
-rw-r--r--net-wireless/horst/horst-9999.ebuild38
1 files changed, 23 insertions, 15 deletions
diff --git a/net-wireless/horst/horst-9999.ebuild b/net-wireless/horst/horst-9999.ebuild
index 7f4bb0baf2b2..3e8968e69d14 100644
--- a/net-wireless/horst/horst-9999.ebuild
+++ b/net-wireless/horst/horst-9999.ebuild
@@ -1,36 +1,44 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit toolchain-funcs git-r3
+EAPI=6
+inherit git-r3 toolchain-funcs
DESCRIPTION="Small 802.11 wireless LAN analyzer"
-HOMEPAGE="https://github.com/br101/horst"
-EGIT_REPO_URI="https://github.com/br101/${PN}"
+HOMEPAGE="http://br1.einfach.org/tech/horst/"
+EGIT_REPO_URI="https://github.com/br101/${PN}/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="debug +pcap test"
-RDEPEND="sys-libs/ncurses:0
- pcap? ( net-libs/libpcap )"
-DEPEND="${RDEPEND}
- test? ( sys-devel/sparse )"
-
-#just semantic tests, no functional tests
-RESTRICT=test
+RDEPEND="
+ sys-libs/ncurses:0
+ pcap? ( net-libs/libpcap )
+"
+TDEPEND="
+ test? ( sys-devel/sparse )
+"
+DEPEND="
+ ${RDEPEND}
+ ${TDEPEND}
+ virtual/pkgconfig
+"
+RESTRICT=test #just semantic tests, no functional tests
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-tinfo.patch
+)
src_compile() {
- tc-export CC
+ tc-export CC PKG_CONFIG
emake PCAP=$(usex pcap 1 0) DEBUG=$(usex debug 1 0)
}
src_install() {
dosbin ${PN}{,.sh}
dodoc README.md
- doman ${PN}.8 ${PN}.conf.5
+ doman ${PN}.8
insinto /etc
doins ${PN}.conf
}