summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/lorcon/lorcon-2020.06.06.ebuild')
-rw-r--r--net-wireless/lorcon/lorcon-2020.06.06.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/net-wireless/lorcon/lorcon-2020.06.06.ebuild b/net-wireless/lorcon/lorcon-2020.06.06.ebuild
deleted file mode 100644
index c43251b94d5d..000000000000
--- a/net-wireless/lorcon/lorcon-2020.06.06.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_OPTIONAL=1
-
-inherit distutils-r1
-
-DESCRIPTION="A generic library for injecting 802.11 frames"
-HOMEPAGE="https://github.com/kismetwireless/lorcon"
-
-if [[ ${PV} == "9999" ]] ; then
- #EGIT_REPO_URI="https://www.kismetwireless.net/lorcon.git"
- EGIT_REPO_URI="https://github.com/kismetwireless/lorcon.git"
- inherit git-r3
- S="${WORKDIR}"/${P}
-else
- SRC_URI="https://github.com/kismetwireless/lorcon/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="python"
-
-DEPEND="
- python? ( ${PYTHON_DEPS} )
- dev-libs/libnl:3=
- net-libs/libpcap"
-RDEPEND="${DEPEND}"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="test"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git-r3_src_unpack
- cp -R "${S}/" "${WORKDIR}/all"
- fi
- default_src_unpack
-}
-
-src_prepare() {
- default
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- econf --disable-static
-}
-
-src_compile() {
- default_src_compile
- if use python; then
- LDFLAGS+=" -L${S}/.libs/"
- cd pylorcon2 || die
- distutils-r1_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
- if use python; then
- cd pylorcon2 || die
- distutils-r1_src_install
- fi
- find "${ED}" -name '*.la' -delete || die
-}