summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/madwimax/madwimax-0.1.1-r1.ebuild')
-rw-r--r--net-wireless/madwimax/madwimax-0.1.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-wireless/madwimax/madwimax-0.1.1-r1.ebuild b/net-wireless/madwimax/madwimax-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..e24882caf98a
--- /dev/null
+++ b/net-wireless/madwimax/madwimax-0.1.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools linux-info udev
+
+DESCRIPTION="A reverse-engineered Linux driver for mobile WiMAX devices based on Samsung CMC-730 chip"
+HOMEPAGE="http://code.google.com/p/madwimax/"
+SRC_URI="http://madwimax.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/asciidoc
+ app-text/docbook2X
+ )"
+
+CONFIG_CHECK="~TUN"
+
+src_prepare() {
+ sed -i -e "s:\(for name in docbook2\)x-man:\1man\.pl:" configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use doc || myconf="--without-man-pages"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" udevrulesdir="$(get_udevdir)"/rules.d install
+ mv "${ED}/$(get_udevdir)"/rules.d/{z60_,60-}madwimax.rules || die
+ dodoc README
+}