summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/uhd/uhd-3.9.6.ebuild')
-rw-r--r--net-wireless/uhd/uhd-3.9.6.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-wireless/uhd/uhd-3.9.6.ebuild b/net-wireless/uhd/uhd-3.9.6.ebuild
index 7ad7928d4f2a..e1278ff8082c 100644
--- a/net-wireless/uhd/uhd-3.9.6.ebuild
+++ b/net-wireless/uhd/uhd-3.9.6.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
+
inherit versionator python-single-r1 gnome2-utils cmake-utils multilib
DESCRIPTION="Universal Software Radio Peripheral (USRP) Hardware Driver"
@@ -13,13 +15,15 @@ SRC_URI="https://github.com/EttusResearch/uhd/archive/release_00$(get_version_co
http://files.ettus.com/binaries/images/${image_version}.zip"
#https://github.com/EttusResearch/UHD-Mirror/tags
#http://files.ettus.com/binaries/images/
-KEYWORDS="~amd64 ~arm ~x86"
-S="${WORKDIR}"/uhd-release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3)/host
LICENSE="GPL-3"
SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
-RDEPEND="virtual/libusb:1
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ virtual/libusb:1
dev-lang/orc
dev-libs/boost:=
sys-libs/ncurses:0
@@ -29,6 +33,8 @@ DEPEND="${RDEPEND}
dev-python/cheetah
app-arch/unzip"
+S="${WORKDIR}"/uhd-release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3)/host
+
src_prepare() {
gnome2_environment_reset #534582