summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/galaxy/galaxy-2.2-r1.ebuild')
-rw-r--r--sci-astronomy/galaxy/galaxy-2.2-r1.ebuild27
1 files changed, 6 insertions, 21 deletions
diff --git a/sci-astronomy/galaxy/galaxy-2.2-r1.ebuild b/sci-astronomy/galaxy/galaxy-2.2-r1.ebuild
index bce80f743988..88341dfa0584 100644
--- a/sci-astronomy/galaxy/galaxy-2.2-r1.ebuild
+++ b/sci-astronomy/galaxy/galaxy-2.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit fdo-mime flag-o-matic toolchain-funcs
+inherit flag-o-matic toolchain-funcs xdg
# probably change every release
PID="1/3/0/3/13035936"
@@ -15,31 +15,16 @@ SRC_URI="http://www.kornelix.com/uploads/${PID}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
DEPEND="x11-libs/gtk+:3"
RDEPEND="${DEPEND}
x11-misc/xdg-utils"
+BDEPEND="virtual/pkgconfig"
-src_prepare() {
- default
- sed -e '/DOCDIR/ s/PROGRAM)/&-\$(VERSION)/g' \
- -e '/xdg-desktop-menu/d' \
- -i Makefile || die
-}
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
src_configure() {
- tc-export CXX
+ tc-export CXX PKG_CONFIG
append-cxxflags -pthread
append-ldflags -pthread
- export PREFIX="${EPREFIX}/usr"
- default
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
}