summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/xephem/xephem-3.7.7-r1.ebuild')
-rw-r--r--sci-astronomy/xephem/xephem-3.7.7-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sci-astronomy/xephem/xephem-3.7.7-r1.ebuild b/sci-astronomy/xephem/xephem-3.7.7-r1.ebuild
new file mode 100644
index 000000000000..6b0253ce91eb
--- /dev/null
+++ b/sci-astronomy/xephem/xephem-3.7.7-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Interactive tool for astronomical ephemeris and sky simulation"
+HOMEPAGE="https://www.clearskyinstitute.com/xephem"
+SRC_URI="https://www.clearskyinstitute.com/xephem/${P}.tgz"
+
+LICENSE="XEphem"
+SLOT=0
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/motif-2.3:0
+ virtual/jpeg:0
+ media-libs/libpng:0="
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/groff"
+
+HTML_DOCS=( GUI/xephem/help/. )
+DOCS=( README )
+
+PATCHES=(
+ "${FILESDIR}/${P}-respect_env_vars.patch"
+ "${FILESDIR}/${P}-implicits.patch"
+ "${FILESDIR}/${P}-no_xprint.patch"
+)
+
+src_compile() {
+ tc-export CC AR RANLIB
+ emake -C GUI/xephem
+}
+
+src_install() {
+ insinto /usr/share/X11/app-defaults
+ newins - XEphem <<-EOF
+ XEphem.ShareDir: /usr/share/${PN}
+ EOF
+ newenvd - 99xephem <<-EOF
+ XEHELPURL=/usr/share/doc/${PF}/html/xephem.html
+ EOF
+ einstalldocs
+
+ cd GUI/xephem || die
+ dobin xephem
+ doman xephem.1
+ newicon XEphem.png ${PN}.png
+ insinto /usr/share/${PN}
+ doins -r auxil catalogs fifos fits gallery lo
+ make_desktop_entry xephem XEphem ${PN}
+}