summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/siril/Manifest1
-rw-r--r--sci-astronomy/siril/files/siril-1.2-stdint.patch33
-rw-r--r--sci-astronomy/siril/files/siril-1.2-tiff.patch56
-rw-r--r--sci-astronomy/siril/siril-1.2.0_rc1.ebuild92
4 files changed, 182 insertions, 0 deletions
diff --git a/sci-astronomy/siril/Manifest b/sci-astronomy/siril/Manifest
index 3b4007fb5011..21fb2bfbef3a 100644
--- a/sci-astronomy/siril/Manifest
+++ b/sci-astronomy/siril/Manifest
@@ -1,2 +1,3 @@
DIST siril-1.0.6.tar.bz2 2893872 BLAKE2B 1f254dcb774c4bfb14fee4626d40e6eeedf866a7a96dca98502cd84e66b973c2201b1f88e2efcb89ce3401b13bd87a319b2ff11e7ba100d0689c9df429d01957 SHA512 afb5f1768a5884adcc13f2afd6fa386d836df5a1385b916df9df8da1fb464e0c8738123fb485ed92c749e596c744d5252a66444b840223488a0860e9324c4e9d
DIST siril-1.2.0-beta1.tar.bz2 3869827 BLAKE2B 4ba624e917234f389f3ac1f2baf7519aacf4da6494ff437491103491dcac60ff146665faf0daf700a4d2e375d098b3b9af75c60975b882600ab96700a4dff166 SHA512 e259f46e2792d59f53d1e9e5fd3b33c6a912a9c19b53c4d84a803f153e1c5c4395f2fb413a21887330f41e06b7d62996162e65e73774faadb47ff7edc9f4150d
+DIST siril-1.2.0-rc1.tar.bz2 4353720 BLAKE2B 38c7b1585508ac9697847648f2d718899a296a4061b34fcf71424136daa50c68737f811fd9063aa80274708d085d8089dceff7d1fd25277b60f0482c17fa5cd1 SHA512 41d685c0aca79da8a9c17d729c710bdd51d3f8cd13b976fb4aad4750e74b600783b988246f008cf41246e7e5f05b8b42368d975cbd79f42e9121b39e367eb22f
diff --git a/sci-astronomy/siril/files/siril-1.2-stdint.patch b/sci-astronomy/siril/files/siril-1.2-stdint.patch
new file mode 100644
index 000000000000..a8fb39c2bd5d
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-1.2-stdint.patch
@@ -0,0 +1,33 @@
+Upstream: https://gitlab.com/free-astro/siril/-/merge_requests/525
+--- a/src/core/exif.h
++++ b/src/core/exif.h
+@@ -20,6 +20,8 @@
+ #ifndef SRC_CORE_EXIF_H_
+ #define SRC_CORE_EXIF_H_
+
++#include <stdint.h>
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+--- a/src/io/avi_pipp/pipp_avi_write_dib.h
++++ b/src/io/avi_pipp/pipp_avi_write_dib.h
+@@ -1,6 +1,8 @@
+ #ifndef PIPP_AVI_WRITE_DIB_H
+ #define PIPP_AVI_WRITE_DIB_H
+
++#include <cstdint>
++
+ #include "pipp_video_write.h"
+ #include "pipp_avi_write.h"
+
+--- a/src/io/avi_pipp/pipp_buffer.h
++++ b/src/io/avi_pipp/pipp_buffer.h
+@@ -19,7 +19,6 @@
+ #ifndef PIPP_BUFFER_H
+ #define PIPP_BUFFER_H
+
+-#include <cstdint>
+ #include <cstdint>
+ #include <cstddef>
+
diff --git a/sci-astronomy/siril/files/siril-1.2-tiff.patch b/sci-astronomy/siril/files/siril-1.2-tiff.patch
new file mode 100644
index 000000000000..9e84f12c645b
--- /dev/null
+++ b/sci-astronomy/siril/files/siril-1.2-tiff.patch
@@ -0,0 +1,56 @@
+https://gitlab.com/free-astro/siril/-/commit/de5030991caa9490c510651868783faae2530089
+From: Cyril Richard <cyril.richard42@gmail.com>
+Date: Sun, 11 Jun 2023 23:40:10 +0200
+Subject: [PATCH] Fixing compiler error with no libtiff
+Upstream: https://gitlab.com/free-astro/siril/-/issues/1129
+
+--- a/src/gui/preferences.c
++++ b/src/gui/preferences.c
+@@ -299,6 +299,7 @@ void initialize_path_directory(const gchar *path) {
+ }
+
+ void initialize_starnet_executable(const gchar *path) {
++#ifdef HAVE_LIBTIFF
+ GtkFileChooser *starnet_exe = GTK_FILE_CHOOSER(lookup_widget("filechooser_starnet"));
+ GtkWidget *starnet_weights_reset = GTK_WIDGET(lookup_widget("starnet_weights_clear"));
+ GtkWidget *starnet_weights = GTK_WIDGET(lookup_widget("filechooser_starnet_weights"));
+@@ -315,6 +316,7 @@ void initialize_starnet_executable(const gchar *path) {
+ gtk_widget_set_sensitive(starnet_weights, FALSE);
+ gtk_widget_set_sensitive(starnet_weights_reset, FALSE);
+ }
++#endif
+ }
+
+ void initialize_starnet_weights(const gchar *path) {
+@@ -404,6 +406,7 @@ void on_filechooser_swap_file_set(GtkFileChooserButton *fileChooser, gpointer us
+ }
+
+ void on_filechooser_starnet_file_set(GtkFileChooserButton *fileChooser, gpointer user_data) {
++#ifdef HAVE_LIBTIFF
+ GtkFileChooser *starnet_exe = GTK_FILE_CHOOSER(fileChooser);
+ gchar *path;
+
+@@ -429,7 +432,7 @@ void on_filechooser_starnet_file_set(GtkFileChooserButton *fileChooser, gpointer
+ gtk_widget_set_sensitive(starnet_weights, FALSE);
+ gtk_widget_set_sensitive(starnet_weights_reset, FALSE);
+ }
+-
++#endif
+ }
+
+ void on_starnet_weights_clear_clicked(GtkButton *button, gpointer user_data) {
+--- a/src/io/sequence_export.c
++++ b/src/io/sequence_export.c
+@@ -650,7 +650,9 @@ void on_buttonExportSeq_clicked(GtkButton *button, gpointer user_data) {
+ // add a trailing '_' for multiple-files sequences
+ args->basename = format_basename(args->basename, TRUE);
+ if (args->output == EXPORT_TIFF) {
++#ifdef HAVE_LIBTIFF
+ args->tiff_compression = get_tiff_compression();
++#endif
+ }
+ }
+ // Display a useful warning because I always forget to remove selection
+--
+GitLab
+
diff --git a/sci-astronomy/siril/siril-1.2.0_rc1.ebuild b/sci-astronomy/siril/siril-1.2.0_rc1.ebuild
new file mode 100644
index 000000000000..93988e8161cb
--- /dev/null
+++ b/sci-astronomy/siril/siril-1.2.0_rc1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature toolchain-funcs xdg
+
+DESCRIPTION="A free astronomical image processing software"
+HOMEPAGE="https://www.siril.org/"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/free-astro/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/free-astro/siril/-/archive/${PV/_/-}/${PN}-${PV/_/-}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
+LICENSE="GPL-3+ Boost-1.0"
+SLOT="0"
+IUSE="curl exif ffmpeg heif jpeg libconfig openmp png raw tiff wcs"
+
+DEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=dev-libs/json-glib-1.2.6
+ dev-libs/sleef:=
+ media-libs/librtprocess:=
+ >=media-libs/opencv-4.4.0:=
+ sci-libs/cfitsio
+ sci-libs/fftw:3.0=
+ sci-libs/gsl:=
+ x11-libs/cairo
+ >=x11-libs/gtk+-3.20.0:3
+ curl? ( net-misc/curl )
+ exif? ( >=media-gfx/exiv2-0.25 )
+ ffmpeg? ( media-video/ffmpeg:= )
+ heif? ( media-libs/libheif )
+ libconfig? ( >=dev-libs/libconfig-1.4[cxx] )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( >=media-libs/libpng-1.6.0 )
+ raw? ( media-libs/libraw )
+ tiff? ( media-libs/tiff:= )
+ wcs? ( >=sci-astronomy/wcslib-7.7 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="dev-util/cmake
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-docfiles.patch"
+ "${FILESDIR}/${PN}-$(ver_cut 1-2)-stdint.patch"
+ "${FILESDIR}/${PN}-$(ver_cut 1-2)-tiff.patch"
+)
+
+DOCS=( README.md NEWS ChangeLog AUTHORS )
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dffms2=false
+ -Dcriterion=false
+ $(meson_use exif exiv2)
+ $(meson_use ffmpeg)
+ $(meson_use heif libheif)
+ $(meson_use jpeg libjpeg)
+ $(meson_use libconfig)
+ $(meson_use openmp)
+ $(meson_use png libpng)
+ $(meson_use raw libraw)
+ $(meson_use tiff libtiff)
+ $(meson_use wcs wcslib)
+ $(usex curl -Denable-libcurl=yes -Denable-libcurl=no)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ optfeature "gnuplot support" sci-visualization/gnuplot
+}