summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bedtools')
-rw-r--r--sci-biology/bedtools/Manifest1
-rw-r--r--sci-biology/bedtools/bedtools-2.30.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-biology/bedtools/Manifest b/sci-biology/bedtools/Manifest
index 5dc912159a45..d2d1a7150f72 100644
--- a/sci-biology/bedtools/Manifest
+++ b/sci-biology/bedtools/Manifest
@@ -1 +1,2 @@
DIST bedtools-2.29.2.tar.gz 20646485 BLAKE2B cdfff7a0f5300f31c2487e98bd28dc7e8b7f3575a098947c2c7b3a6e30272a80d35f07997d3a00bd42d91bf60899f32358b25b054b6f40b761cc66e2788508b3 SHA512 138ff029995e9889d2e43f884fa15bb5614d11cf75dfe18e2999aad0915e80f49444e67c9934c92ca8e28caad399394b493db8a1bee9f5304413a8c41c22c6d5
+DIST bedtools-2.30.0.tar.gz 20648577 BLAKE2B 042bc31e846455cb1c20199f7a27a3850851f7c256a45b1e674c7aa48ecedc211b0fdfc5e25f915b588f21447e757ebff2bba16a65905bb10d3c88e4b17b1db1 SHA512 3993243cc3db12d194d6220aeae200e6af843d6d32d4e5a9a82d04c9d119f8ed47e618e87241edfa82cfac081bc9a40ada18f097d21b0cafc5f912ae012701c9
diff --git a/sci-biology/bedtools/bedtools-2.30.0.ebuild b/sci-biology/bedtools/bedtools-2.30.0.ebuild
new file mode 100644
index 000000000000..3647f43dabe5
--- /dev/null
+++ b/sci-biology/bedtools/bedtools-2.30.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-any-r1 toolchain-funcs
+
+DESCRIPTION="Tools for manipulation and analysis of BED, GFF/GTF, VCF, SAM/BAM file formats"
+HOMEPAGE="https://bedtools.readthedocs.io/"
+SRC_URI="https://github.com/arq5x/${PN}2/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ test? ( >=sci-biology/samtools-1.10:0 )"
+
+S="${WORKDIR}"/${PN}2
+
+# bedtools2 has a *terrible* build system and development practices.
+# Upstream has forked htslib 1.9 and extended it by adding clever callbacks
+# that make unbundling it nigh impossible. There are no signs of upstream porting
+# their fork to 1.10, which means we're stuck with the bundled version.
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.29.2-buildsystem.patch
+ "${FILESDIR}"/${PN}-2.29.2-python.patch
+)
+
+src_configure() {
+ tc-export AR CC CXX RANLIB
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}
+ doins -r genomes
+}