summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/embassy-emnu/embassy-emnu-1.05.660-r1.ebuild')
-rw-r--r--sci-biology/embassy-emnu/embassy-emnu-1.05.660-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-biology/embassy-emnu/embassy-emnu-1.05.660-r1.ebuild b/sci-biology/embassy-emnu/embassy-emnu-1.05.660-r1.ebuild
new file mode 100644
index 000000000000..8f26aee861c1
--- /dev/null
+++ b/sci-biology/embassy-emnu/embassy-emnu-1.05.660-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EBO_DESCRIPTION="Simple menu of EMBOSS applications"
+
+inherit autotools emboss-r3
+
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/EMNU-1.05.650"
+PATCHES=( "${FILESDIR}"/${PN}-1.05.650_fix-build-system.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-curses is not a thing,
+ # EMNU hard depends on ncurses really, #752216
+ emboss-r3_src_configure --enable-curses
+}