summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/maq/maq-0.7.1-r2.ebuild')
-rw-r--r--sci-biology/maq/maq-0.7.1-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/maq/maq-0.7.1-r2.ebuild b/sci-biology/maq/maq-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..fb0140047ae4
--- /dev/null
+++ b/sci-biology/maq/maq-0.7.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Mapping and Assembly with Qualities, mapping NGS reads to reference genomes"
+HOMEPAGE="http://maq.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://sourceforge/${PN}/calib-36.dat.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-bfr-overfl.patch
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ "${FILESDIR}"/${P}-remove-64bit-flag.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}
+ doins "${WORKDIR}"/*.dat
+
+ doman maq.1
+ dodoc ${PN}.pdf
+}