summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/piler/files/piler-1.0-fix-build-system.patch')
-rw-r--r--sci-biology/piler/files/piler-1.0-fix-build-system.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-biology/piler/files/piler-1.0-fix-build-system.patch b/sci-biology/piler/files/piler-1.0-fix-build-system.patch
new file mode 100644
index 000000000000..78a72f1b4850
--- /dev/null
+++ b/sci-biology/piler/files/piler-1.0-fix-build-system.patch
@@ -0,0 +1,34 @@
+Make build system honour user variables
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,4 @@
+-CFLAGS = -O3 -march=pentiumpro -mcpu=pentiumpro -funroll-loops -Winline -DNDEBUG=1
+-LDLIBS = -lm -static
+-# LDLIBS = -lm
++LDLIBS = -lm
+
+ OBJ = .o
+ EXE =
+@@ -8,18 +6,13 @@
+ RM = rm -f
+ CP = cp
+
+-GPP = g++
+-LD = $(GPP) $(CFLAGS)
+-CPP = $(GPP) -c $(CFLAGS)
+-CC = gcc -c $(CFLAGS)
+-
+ all: piler
+
+ CPPSRC = $(sort $(wildcard *.cpp))
+ CPPOBJ = $(subst .cpp,.o,$(CPPSRC))
+
+-$(CPPOBJ): %.o: %.cpp
+- $(CPP) $< -o $@
++%.o: %.cpp
++ $(CXX) $(CXXFLAGS) -DNDEBUG $(CPPFLAGS) -c $< -o $@
+
+ piler: $(CPPOBJ)
+- $(LD) -o piler $(CPPOBJ) $(LDLIBS)
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o piler $(CPPOBJ) $(LDLIBS)