summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/seqan/seqan-2.4.0.ebuild')
-rw-r--r--sci-biology/seqan/seqan-2.4.0.ebuild27
1 files changed, 10 insertions, 17 deletions
diff --git a/sci-biology/seqan/seqan-2.4.0.ebuild b/sci-biology/seqan/seqan-2.4.0.ebuild
index 5653a1ec94e4..cf73c6984d0e 100644
--- a/sci-biology/seqan/seqan-2.4.0.ebuild
+++ b/sci-biology/seqan/seqan-2.4.0.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-
-inherit cmake-utils multibuild toolchain-funcs
+inherit cmake multibuild toolchain-funcs
DESCRIPTION="C++ Sequence Analysis Library"
-HOMEPAGE="http://www.seqan.de/"
+HOMEPAGE="https://www.seqan.de/"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -17,8 +15,7 @@ if [[ ${PV} == *9999 ]]; then
else
SRC_URI="https://github.com/seqan/seqan/archive/seqan-v${PV}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
- S=${WORKDIR}/seqan-seqan-v${PV}
+ S="${WORKDIR}"/seqan-seqan-v${PV}
fi
LICENSE="BSD GPL-3"
@@ -32,8 +29,7 @@ RDEPEND="
!!sci-biology/seqan:2.0
!!sci-biology/seqan:2.1
!!sci-biology/seqan:2.2"
-DEPEND="
- ${RDEPEND}"
+DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${PN}-2.4.0-fix-pthread.patch )
@@ -41,10 +37,7 @@ pkg_setup() {
if [[ ${MERGE_TYPE} != binary ]]; then
use tools && tc-check-openmp
- MULTIBUILD_VARIANTS=(
- $(usev tools)
- library
- )
+ MULTIBUILD_VARIANTS=( $(usev tools) library )
fi
}
@@ -69,15 +62,15 @@ src_configure() {
die "${MULTIBUILD_ID} is not recognized"
;;
esac
- cmake-utils_src_configure
+ cmake_src_configure
}
multibuild_foreach_variant my_configure
}
src_compile() {
- multibuild_foreach_variant cmake-utils_src_compile
+ multibuild_foreach_variant cmake_src_compile
}
src_install() {
- multibuild_foreach_variant cmake-utils_src_install
+ multibuild_foreach_variant cmake_src_install
}