summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mrbayes/Manifest1
-rw-r--r--sci-biology/mrbayes/metadata.xml19
-rw-r--r--sci-biology/mrbayes/mrbayes-3.2.7.ebuild45
3 files changed, 56 insertions, 9 deletions
diff --git a/sci-biology/mrbayes/Manifest b/sci-biology/mrbayes/Manifest
index 799aafc484a4..3d68a52ee87a 100644
--- a/sci-biology/mrbayes/Manifest
+++ b/sci-biology/mrbayes/Manifest
@@ -1 +1,2 @@
DIST mrbayes-3.1.2.tar.gz 545968 BLAKE2B f4c5bbdde765fb9e596c17d5fd890b168c22cefb0d24b67c1c68623e1dcfa4df716a896fe120f7a1cac4234125b6ed524973506e47492ba3ec26e389783d618a SHA512 2fb0ee7224cbb69c1acf2ffb0c6c8974f63002cda4f39a626eadf80fad9cfc23861f8c03f5545970f3a81e02093d62b6a0549ab7d7f7080557e91e21b2c3ee14
+DIST mrbayes-3.2.7.tar.gz 9787214 BLAKE2B 2d0ebbc376712e15fc1ed146053d977ad1af96f44c31b8fd0fdbd47ef9bafc41cbb8904db94bc8d30c753c0267a1dcce0d08c73d8b35c20e0f15206bc8fef6ff SHA512 4dc869cd07cf384b3a3945ac8d91a7cc2982e8c5cd8d1f097b46a479a071cb71e71c60e152aa4fc01b0bb296295c5fa9f5a48aa8e913b920c33e30cbb3a6ed37
diff --git a/sci-biology/mrbayes/metadata.xml b/sci-biology/mrbayes/metadata.xml
index 348542381e73..2fbcd4fa4f98 100644
--- a/sci-biology/mrbayes/metadata.xml
+++ b/sci-biology/mrbayes/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
- <longdescription>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <longdescription>
MrBayes is a program for the Bayesian estimation of phylogeny.
Bayesian inference of phylogeny is based upon a quantity called the
posterior probability distribution of trees, which is the probability of a
@@ -14,8 +14,9 @@ Bayes's theorem. The posterior probability distribution of trees is
impossible to calculate analytically; instead, MrBayes uses a simulation
technique called Markov chain Monte Carlo (or MCMC) to approximate the
posterior probabilities of trees.
-</longdescription>
- <upstream>
- <remote-id type="sourceforge">mrbayes</remote-id>
- </upstream>
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">mrbayes</remote-id>
+ <remote-id type="github">NBISweden/MrBayes</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sci-biology/mrbayes/mrbayes-3.2.7.ebuild b/sci-biology/mrbayes/mrbayes-3.2.7.ebuild
new file mode 100644
index 000000000000..ad87554eb31e
--- /dev/null
+++ b/sci-biology/mrbayes/mrbayes-3.2.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Bayesian Inference of Phylogeny"
+HOMEPAGE="https://nbisweden.github.io/MrBayes/"
+SRC_URI="https://github.com/NBISweden/MrBayes/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="debug mpi readline"
+# --with-readline was given, but MPI support requires readline to be disabled.
+REQUIRED_USE="mpi? ( !readline )"
+
+DEPEND="
+ sys-libs/ncurses:=
+ mpi? ( virtual/mpi )
+ readline? ( sys-libs/readline:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ "$(use_with mpi)" \
+ "$(use_with readline)" \
+ "$(use_enable debug )" \
+ # configure checks cpuid and enables fma{3,4}, sse{1..4} if detected.
+ # Configure options only allow disabling the auto-detection, but do not
+ # actually allow toggling the individual cpu instruction sets. The only
+ # way to guarantee that cross-compiling and binpkgs will work on machines
+ # other than the host is to unconditionally disable sse/fma/avx.
+ #"$(use_enable cpu_flags_x86_sse sse )" \
+ #"$(use_enable cpu_flags_x86_avx avx )" \
+ #"$(use_enable cpu_flags_x86_fma3 fma )" \
+ # Has optional support for sci-biology/beagle::science
+ # "$(use_with beagle)"
+}
+
+src_compile() {
+ # The --disable options for the cpu instruction sets don't actually work so
+ # we override it here and also set the user specified CFLAGS.
+ emake SIMD_FLAGS= CPUEXT_FLAGS= CFLAGS="${CFLAGS}"
+}