summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild')
-rw-r--r--sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild b/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild
index e76181650805..c9740ad088e8 100644
--- a/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild
+++ b/sci-calculators/hexcalc/hexcalc-1.11-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,15 +16,19 @@ IUSE=""
RDEPEND="x11-libs/libXaw"
DEPEND="${RDEPEND}
- x11-misc/imake
+ >=x11-misc/imake-1.0.8-r1
app-text/rman"
S=${WORKDIR}/${PN}
PATCHES=( "${FILESDIR}"/${PN}-{keypad,order}.diff )
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+}
+
src_compile() {
- xmkmf || die
emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \