summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/speedcrunch/speedcrunch-0.12.0-r1.ebuild')
-rw-r--r--sci-calculators/speedcrunch/speedcrunch-0.12.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-calculators/speedcrunch/speedcrunch-0.12.0-r1.ebuild b/sci-calculators/speedcrunch/speedcrunch-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..cc9c48df2737
--- /dev/null
+++ b/sci-calculators/speedcrunch/speedcrunch-0.12.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake desktop xdg-utils
+
+DESCRIPTION="Fast and usable calculator for power users"
+HOMEPAGE="https://speedcrunch.org/"
+SRC_URI="https://bitbucket.org/heldercorreia/${PN}/get/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/heldercorreia-speedcrunch-ea93b21f9498/src"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qthelp:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-appdata.patch" )
+
+src_install() {
+ use doc && local HTML_DOCS=( ../doc/build_html_embedded/. )
+ cmake_src_install
+ doicon -s scalable ../gfx/speedcrunch.svg
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}