summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/hcalc/files/hcalc-1.2-clang16.patch26
-rw-r--r--sci-calculators/hcalc/hcalc-1.2-r1.ebuild7
2 files changed, 31 insertions, 2 deletions
diff --git a/sci-calculators/hcalc/files/hcalc-1.2-clang16.patch b/sci-calculators/hcalc/files/hcalc-1.2-clang16.patch
new file mode 100644
index 000000000000..19b08726b18e
--- /dev/null
+++ b/sci-calculators/hcalc/files/hcalc-1.2-clang16.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/870514
+--- a/draw.c
++++ b/draw.c
+@@ -63,2 +63,3 @@
+
++void
+ set_bits(int b)
+@@ -70,2 +71,3 @@
+
++void
+ set_string(char *s)
+--- a/hcalc.h
++++ b/hcalc.h
+@@ -37 +37,12 @@
+ #define HEIGHT 294
++
++void button(int b, int x, int y);
++void complete_paste(char *s, int n);
++void key(char c);
++void load_pixmaps(void);
++void process_input(void);
++void redraw(void);
++void send_current_display(void);
++void set_bits(int b);
++void set_string(char *s);
++void setup_x(int argc, char **argv);
diff --git a/sci-calculators/hcalc/hcalc-1.2-r1.ebuild b/sci-calculators/hcalc/hcalc-1.2-r1.ebuild
index 6a6b90666a0a..b124b7c65f89 100644
--- a/sci-calculators/hcalc/hcalc-1.2-r1.ebuild
+++ b/sci-calculators/hcalc/hcalc-1.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,10 @@ RDEPEND="
x11-libs/libXpm"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
pkg_postinst() {
einfo "Enter hcalc to run and use kill or ctrl-c to exit."