summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild b/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
index 20e117cd6853..729630099a29 100644
--- a/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
+++ b/sci-calculators/hexcalc/hexcalc-1.11-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Simple hex calculator for X"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
@@ -32,6 +32,8 @@ PATCHES=(
)
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}