summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild')
-rw-r--r--sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild29
1 files changed, 16 insertions, 13 deletions
diff --git a/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild b/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild
index bbff27f85e2f..59f14e8086c9 100644
--- a/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild
+++ b/sci-chemistry/autodock_vina/autodock_vina-1.1.2.ebuild
@@ -1,40 +1,43 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils flag-o-matic versionator
+inherit flag-o-matic
-MY_P="${PN}_$(replace_all_version_separators _)"
+MY_P="${PN}_$(ver_rs 1- _)"
DESCRIPTION="Program for drug discovery, molecular docking and virtual screening"
HOMEPAGE="http://vina.scripps.edu/"
SRC_URI="http://vina.scripps.edu/download/${MY_P}.tgz"
+LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
-LICENSE="Apache-2.0"
IUSE="debug"
-RDEPEND="dev-libs/boost[threads]"
+RDEPEND="dev-libs/boost:=[threads]"
DEPEND="${RDEPEND}"
S="${WORKDIR}"/${MY_P}/build/linux/release
+PATCHES=(
+ "${FILESDIR}"/${PV}-gentoo.patch
+ "${FILESDIR}"/${P}-boost-filesystem.patch
+ "${FILESDIR}"/${P}-missing-debug-decl.patch
+)
+
src_prepare() {
cd "${WORKDIR}"/${MY_P} || die
- epatch \
- "${FILESDIR}"/${PV}-gentoo.patch \
- "${FILESDIR}"/${P}-boost-filesystem.patch
+ default
}
-src_compile() {
- local c_options
-
+src_configure() {
use debug || c_options="-DNDEBUG"
-
append-cxxflags -DBOOST_FILESYSTEM_VERSION=3
+}
+src_compile() {
emake \
BASE="${EPREFIX}"/usr/ \
GPP="$(tc-getCXX)" \