summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/chemex')
-rw-r--r--sci-chemistry/chemex/Manifest1
-rw-r--r--sci-chemistry/chemex/chemex-2022.3.6.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sci-chemistry/chemex/Manifest b/sci-chemistry/chemex/Manifest
index e700db25c152..58d94a4f645c 100644
--- a/sci-chemistry/chemex/Manifest
+++ b/sci-chemistry/chemex/Manifest
@@ -1,2 +1,3 @@
DIST chemex-2022.3.4.tar.gz 2845201 BLAKE2B 91a76bdb54857710d482b14e36d24adec8706c385da7300d8cf7189426af28651877d487eb061e26656432575eb711de0e3a92724d1488d99efcdc8a682b59bd SHA512 304af730149a2f6723bbe36c0deafb826392cd571a2b4245bb42e28612ceef3ee2ca989f1909ddc7709081f742a997469565ef7d02994fda8087372f29e1dfe1
DIST chemex-2022.3.5.tar.gz 2845347 BLAKE2B 29b53ba8afcfd91e4f50119f212557de85d8576474b74d2ad925c8c2adb89397640e7b352b6785dc99a8c4e5007294609640219b2374cbb3144f94c5f9113d96 SHA512 3a92702d105e95e0a7b15e01b839d5982df55477afb98e58f7458a0e87230e94597c01d33c219ae469ed62e4ddaecdb787ae435453d428843d5a612159715d2b
+DIST chemex-2022.3.6.tar.gz 2843118 BLAKE2B e51b385dbf9e3c42f54f95f9929125e3263e12afa62beab8e5b8eb13e78a4fe9a0fb445f4f6c3cd4aa8e71748732ec58124682daa86be079eed036b78492ca71 SHA512 5c734e1b3ea39e9729bada93dfe5bc55f877b69ba6edd9612f95aab0d31949489582957a14f175646c7e6652644a5a55c26bcd74affc7fecc1e7b9cfdd4ceb63
diff --git a/sci-chemistry/chemex/chemex-2022.3.6.ebuild b/sci-chemistry/chemex/chemex-2022.3.6.ebuild
new file mode 100644
index 000000000000..81b3e45f7856
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2022.3.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL="yes"
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/ChemEx/archive/refs/tags/${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ChemEx-${PV/_p/-dev}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="test"
+
+#RESTRICT="!test? ( test )"
+# FIXME: Restrict until tests are readded https://github.com/gbouvignies/ChemEx/issues/51
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cachetools-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/lmfit-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-3.7.1[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/rapidfuzz-3.1.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.4.2[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.9.3[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}