summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/dssp')
-rw-r--r--sci-chemistry/dssp/Manifest1
-rw-r--r--sci-chemistry/dssp/dssp-4.2.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/Manifest b/sci-chemistry/dssp/Manifest
index 3fd55461432a..0dd96b30e667 100644
--- a/sci-chemistry/dssp/Manifest
+++ b/sci-chemistry/dssp/Manifest
@@ -2,3 +2,4 @@ DIST dssp-2.2.1.tgz 47141 BLAKE2B 34d8b2db8797a8c23763766c0214337f03584c4be52c1b
DIST dssp-3.0.11.tar.gz 168085 BLAKE2B e1c42fd22cfb2287f10b5deae48b56a4583d4a67737a3485dcbd160d1597a15c2d5105c3794c875d8001abede1c014efb4f7f5b7c250f867bdf9ed95a0860217 SHA512 a0cfe44e517ff1f909ef2928b62ae2c639c6bddfd8a0fb538883f647fd2771e00da68e0fd2521aa02ba3c6d1b0c9b784b7fe142392af3a3abf6ea89f1546bd9d
DIST dssp-4.0.3.tar.gz 122872 BLAKE2B f88c330370645b4bd4e89656ad676e443a33c38d7882145bc60e329f823eb761777713df6c7ae44550d10bcd22256ac16db358587cadd39efd6268dd869655d4 SHA512 31ca481b097c9c59f407e35eb8175638b5e4102991007090b5b4ea30db0b076f97cff45d0aa9ae01a826f7673258464b572d68714f00e210db26020cea4be094
DIST dssp-4.0.4.tar.gz 122183 BLAKE2B b12702c482ad58f09d96e9c85759ebe9455961978277e25d1ee554d07a643b342acf2dbcd3c18d539f058b970c24888a43827b6bac47899ca61bf96dd0c2723b SHA512 e0646bb20f10617174b0970c549fd44990750f46f7a550e4c3bc89487a8d3b7a175d53b2abb0684f9d96203a23d64ae67c6c10688fd4f5f59ff19995f9149ef8
+DIST dssp-4.2.0.tar.gz 157104 BLAKE2B 4caffb5f7cfe2a130e3ac6c5efa41689bbbb8ee054333cd4320cf77ac36dccaa128fe816ca57b6bd287271924122de4252076628098db415c854df6f09c17ac2 SHA512 b86c736ea9fdf62be923f8a69bae56f7298cd01e6623c1f3eee6951e20483d24438b1318924e980b6a98b19c77cb84d4ba66260a575b63e7c536ecba0478c4a5
diff --git a/sci-chemistry/dssp/dssp-4.2.0.ebuild b/sci-chemistry/dssp/dssp-4.2.0.ebuild
new file mode 100644
index 000000000000..2aa19298ec94
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-4.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/ https://github.com/PDB-REDO/dssp"
+SRC_URI="https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="
+ dev-libs/boost:=[zlib]
+ >=dev-libs/libmcfp-1.2.2
+ >=sci-libs/libcifpp-5.0.4
+"
+DEPEND=""
+RDEPEND="${BDEPEND}"
+
+pkg_postinst() {
+ if has_version "<=sci-chemistry/gromacs-2022"; then
+ ewarn "DSSP > 3.0.x is not compatible with gmx do_dssp:"
+ ewarn "https://gitlab.com/gromacs/gromacs/-/issues/4129"
+ ewarn
+ ewarn "Feel free to mask newer versions if needed."
+ fi
+}