summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/dssp')
-rw-r--r--sci-chemistry/dssp/Manifest1
-rw-r--r--sci-chemistry/dssp/dssp-4.4.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/Manifest b/sci-chemistry/dssp/Manifest
index d8219dde5151..f4b46c4fa494 100644
--- a/sci-chemistry/dssp/Manifest
+++ b/sci-chemistry/dssp/Manifest
@@ -2,3 +2,4 @@ DIST dssp-2.2.1.tgz 47141 BLAKE2B 34d8b2db8797a8c23763766c0214337f03584c4be52c1b
DIST dssp-3.0.11.tar.gz 168085 BLAKE2B e1c42fd22cfb2287f10b5deae48b56a4583d4a67737a3485dcbd160d1597a15c2d5105c3794c875d8001abede1c014efb4f7f5b7c250f867bdf9ed95a0860217 SHA512 a0cfe44e517ff1f909ef2928b62ae2c639c6bddfd8a0fb538883f647fd2771e00da68e0fd2521aa02ba3c6d1b0c9b784b7fe142392af3a3abf6ea89f1546bd9d
DIST dssp-4.3.1.tar.gz 226842 BLAKE2B 86318f05b8381d94fa9c65a956f5fb607ef8072b0395d912e20697ba36836c449ddff31a4a64d0005bbfe34899f71853c0f15a911042389fc894934c08fc34c8 SHA512 4dc1a3f5c7ba258ebf548674c7b33c36b0e3a7d14911394eb8d2955c235f3cb1d6c50cb03f411db55a8a9d7aa93e4d03354c47f9f0126b0bdcbf40dc9391d403
DIST dssp-4.4.0.tar.gz 161773 BLAKE2B 87673be73f3163ba6fa090cc7acd4f864d41922033da9d126535b84e2da4defaaa8781a8cda6e80103dc75359718cd867b9baf90c74ae3ff923e212b520998a2 SHA512 1b09306c05587c278fcd881e0d3c169d44d960d8578f310adbd79b054683c257d0ee00d6bdfb5b0d7cd81c224f3572c2c7538a42d964817d587632128b96daa9
+DIST dssp-4.4.1.tar.gz 161797 BLAKE2B d6bfb40a730f39e9d5a0988ce22a9dd377ec08a09e29f77e5afaac26d512cf87f6e289c1e4e3e63cfef7354b10fb57bf410bcc169604b1b6a6078380e4f08d26 SHA512 1bcf9e16efc5d3a7de11e24ed63e47d3263123af4670b8f3daa97cdf7cc33202fb4d564acac3024ed4edcce1ef8278f71f5312f27a234d2957afa6f563c88ed6
diff --git a/sci-chemistry/dssp/dssp-4.4.1.ebuild b/sci-chemistry/dssp/dssp-4.4.1.ebuild
new file mode 100644
index 000000000000..d79883c4e211
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-4.4.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/ https://github.com/PDB-REDO/dssp"
+SRC_URI="https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# doc disabled as it only generates a PDF from the manpage for now
+# https://github.com/PDB-REDO/dssp/issues/64
+#IUSE="doc"
+
+CDEPEND="
+ dev-libs/boost:=[zlib]
+ >=dev-libs/libmcfp-1.2.2
+ >=sci-libs/libcifpp-5.1.0
+"
+BDEPEND="${CDEPEND}"
+# doc? (
+# || ( app-text/pandoc-bin[pandoc-symlink] app-text/pandoc )
+# dev-python/weasyprint
+# )
+DEPEND=""
+RDEPEND="${CDEPEND}"
+
+#src_prepare() {
+# # wkhtmltopdf is not available on Gentoo
+# sed -i -e \
+# 's/-t html/-t html --pdf-engine=weasyprint/' \
+# CMakeLists.txt
+# cmake_src_prepare
+#}
+
+src_configure() {
+ local mycmakeargs=(
+ #-DGENERATE_DOCUMENTATION=$(usex doc)
+ -DGENERATE_DOCUMENTATION=NO
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if has_version "<=sci-chemistry/gromacs-2022"; then
+ ewarn "DSSP > 3.0.x is not compatible with gmx do_dssp:"
+ ewarn "https://gitlab.com/gromacs/gromacs/-/issues/4129"
+ ewarn
+ ewarn "Feel free to mask newer versions if needed."
+ fi
+}