summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild b/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
index 255810902b42..29c88f0d70a6 100644
--- a/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2018.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -147,7 +147,7 @@ src_configure() {
cuda=( "-DGMX_GPU=ON" )
local opencl=( "-DGMX_USE_OPENCL=OFF" )
use opencl && opencl=( "-DGMX_USE_OPENCL=ON" ) cuda=( "-DGMX_GPU=ON" )
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_MPI=OFF
-DGMX_THREAD_MPI=$(usex threads)
@@ -162,7 +162,7 @@ src_configure() {
sed -i '/SET(CMAKE_INSTALL_NAME_DIR/s/^/#/' "${WORKDIR}/${P}_${x}/gentoo_rules.cmake" || die
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
- mycmakeargs=(
+ local mycmakeargs=(
${mycmakeargs_pre[@]} ${p}
-DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON