summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild b/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
index b01b57f54196..71a5399a8a70 100644
--- a/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2019.6-r2.ebuild
@@ -63,9 +63,11 @@ S="${WORKDIR}/${PN}-${PV/_/-}"
PATCHES=( "${FILESDIR}/${P}-missing-include.patch" )
pkg_pretend() {
- [[ $(gcc-version) == "4.1" ]] && die "gcc 4.1 is not supported by gromacs"
- use openmp && ! tc-has-openmp && \
- die "Please switch to an openmp compatible compiler"
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {