summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pdb-tools')
-rw-r--r--sci-chemistry/pdb-tools/Manifest1
-rw-r--r--sci-chemistry/pdb-tools/metadata.xml11
-rw-r--r--sci-chemistry/pdb-tools/pdb-tools-0.2.1-r1.ebuild80
-rw-r--r--sci-chemistry/pdb-tools/pdb-tools-0.2.1-r2.ebuild84
4 files changed, 176 insertions, 0 deletions
diff --git a/sci-chemistry/pdb-tools/Manifest b/sci-chemistry/pdb-tools/Manifest
new file mode 100644
index 000000000000..bf2e4bfa7dce
--- /dev/null
+++ b/sci-chemistry/pdb-tools/Manifest
@@ -0,0 +1 @@
+DIST pdbTools_0.2.1.tar.gz 103835 SHA256 317a5246e806a2b3d0425d080d679646fc77388e3e855412527603f945fa37ae SHA512 9c43c10e8739f8a34dbb1a3bba710cc727f7d8392ff979681371bd4460c67203253fb01852438eb93b214c4a009789608d200ca551f30399652fb76d702cf724 WHIRLPOOL 36d8cf71ba9f9b28e3ad59828539f4e94bbb8bc4514f050ddcbec63857b154ecdc7c32c2945c0d15f4d718c4fe5ab3adcb2e62a4368bfd819b80e9641a9dfd88
diff --git a/sci-chemistry/pdb-tools/metadata.xml b/sci-chemistry/pdb-tools/metadata.xml
new file mode 100644
index 000000000000..13e9a3c93979
--- /dev/null
+++ b/sci-chemistry/pdb-tools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">pdb-tools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/pdb-tools/pdb-tools-0.2.1-r1.ebuild b/sci-chemistry/pdb-tools/pdb-tools-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..ad4ab1dec397
--- /dev/null
+++ b/sci-chemistry/pdb-tools/pdb-tools-0.2.1-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit fortran-2 python-single-r1 toolchain-funcs
+
+MY_PN="pdbTools"
+
+DESCRIPTION="Tools for manipulating and doing calculations on wwPDB macromolecule structure files"
+HOMEPAGE="http://code.google.com/p/pdb-tools/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_PN}_${PV}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ sed \
+ -e "s:script_dir,\"pdb_data\":\"${EPREFIX}/usr/share/${PN}\",\"pdb_data\":g" \
+ -i pdb_sasa.py || die
+ sed \
+ -e "/satk_path =/s:^.*$:satk_path = \"${EPREFIX}/usr/bin\":g" \
+ -i pdb_satk.py || die
+ sed \
+ -e 's:> %:>%:g' \
+ -i pdb_seq.py || die
+}
+
+src_compile() {
+ mkdir bin
+ cd satk
+ for i in *.f; do
+ einfo "$(tc-getFC) ${FFLAGS} ${LDFLAGS} ${i} -o ${i/.f}"
+ $(tc-getFC) ${FFLAGS} -c ${i} -o ${i/.f/.o} || die
+ $(tc-getFC) ${LDFLAGS} -o ../bin/${i/.f} ${i/.f/.o} || die
+ sed \
+ -e "s:${i/.f}.out:${i/.f}:g" \
+ -i ../pdb_satk.py || die
+ done
+}
+
+src_install() {
+ local script
+ insinto /usr/share/${PN}
+ doins -r pdb_data/peptides
+ rm -rf pdb_data/peptides || die
+
+ python_domodule helper pdb_data
+
+ python_moduleinto ${PN/-/_}
+ python_domodule *.py
+
+ for i in pdb_*.py; do
+ cat > ${i/.py} <<- EOF
+ #!${EPREFIX}/bin/bash
+ ${PYTHON} -O "$(python_get_sitedir)/${PN/-/_}/${i}" \$@
+ EOF
+ dobin ${i/.py}
+ done
+
+ dobin bin/*
+ dodoc README
+}
diff --git a/sci-chemistry/pdb-tools/pdb-tools-0.2.1-r2.ebuild b/sci-chemistry/pdb-tools/pdb-tools-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..e56798f3c95b
--- /dev/null
+++ b/sci-chemistry/pdb-tools/pdb-tools-0.2.1-r2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit fortran-2 python-single-r1 toolchain-funcs
+
+MY_PN="pdbTools"
+
+DESCRIPTION="Tools for manipulating and doing calculations on wwPDB macromolecule structure files"
+HOMEPAGE="http://code.google.com/p/pdb-tools/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_PN}_${PV}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ fortran-2_pkg_setup
+}
+
+src_prepare() {
+ sed \
+ -e "s:script_dir,\"pdb_data\":\"${EPREFIX}/usr/share/${PN}\",\"pdb_data\":g" \
+ -i pdb_sasa.py || die
+ sed \
+ -e "/satk_path =/s:^.*$:satk_path = \"${EPREFIX}/usr/bin\":g" \
+ -i pdb_satk.py || die
+ sed \
+ -e 's:> %:>%:g' \
+ -i pdb_seq.py || die
+
+ sed \
+ -e "/import/s:helper:${PN/-/_}.helper:g" \
+ -i *.py || die
+}
+
+src_compile() {
+ mkdir bin
+ cd satk
+ for i in *.f; do
+ einfo "$(tc-getFC) ${FFLAGS} ${LDFLAGS} ${i} -o ${i/.f}"
+ $(tc-getFC) ${FFLAGS} -c ${i} -o ${i/.f/.o} || die
+ $(tc-getFC) ${LDFLAGS} -o ../bin/${i/.f} ${i/.f/.o} || die
+ sed \
+ -e "s:${i/.f}.out:${i/.f}:g" \
+ -i ../pdb_satk.py || die
+ done
+}
+
+src_install() {
+ local script
+ insinto /usr/share/${PN}
+ doins -r pdb_data/peptides
+ rm -rf pdb_data/peptides || die
+
+ python_domodule pdb_data
+
+ python_moduleinto ${PN/-/_}
+ python_domodule helper *.py
+
+ for i in pdb_*.py; do
+ cat > ${i/.py} <<- EOF
+ #!${EPREFIX}/bin/bash
+ ${PYTHON} -O "$(python_get_sitedir)/${PN/-/_}/${i}" \$@
+ EOF
+ dobin ${i/.py}
+ done
+
+ dobin bin/*
+ dodoc README
+}