summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/prekin')
-rw-r--r--sci-chemistry/prekin/Manifest1
-rw-r--r--sci-chemistry/prekin/files/6.51.081122-Makefile.patch39
-rw-r--r--sci-chemistry/prekin/files/6.51.081122-overflow.patch26
-rw-r--r--sci-chemistry/prekin/files/prekin-6.51.081122-fno-common.patch34
-rw-r--r--sci-chemistry/prekin/metadata.xml8
-rw-r--r--sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild49
6 files changed, 0 insertions, 157 deletions
diff --git a/sci-chemistry/prekin/Manifest b/sci-chemistry/prekin/Manifest
deleted file mode 100644
index 79339ac8a7fa..000000000000
--- a/sci-chemistry/prekin/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST prekin.6.51.081122.src.tgz 350756 BLAKE2B 657706e83d06be74f2565abb4db1c886c19247b736200cf309cc143f71c7f47e4c85d869b286ec3e250ecb0d714e1454044836001aa6b883513d9149683bb320 SHA512 9a41f30a9de955c78ee5685807482b2b073705643cceb53bf57eaf7c0c4753dc88fa8dc19f09d4c8a07124c3c3c73716f29126860ae37ff4dd6fb6178b829d1f
diff --git a/sci-chemistry/prekin/files/6.51.081122-Makefile.patch b/sci-chemistry/prekin/files/6.51.081122-Makefile.patch
deleted file mode 100644
index b562f27e51d3..000000000000
--- a/sci-chemistry/prekin/files/6.51.081122-Makefile.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/Makefile.linux
-+++ b/Makefile.linux
-@@ -1,15 +1,15 @@
- #
--CFLAGS = -I/usr/X11R6/include
-+CFLAGS += -I/usr/X11R6/include
-
- ifeq ($(MAKECMDGOALS),debug)
- CFLAGS = -g -I/usr/X11R6/include
- endif
-
--LIBS = -L/usr/lib -L/usr/X11R6/lib -lXmu -lXm -lXt -lSM -lICE -lXext -lX11
-+LIBS = -L/usr/GENTOOLIBDIR -L/usr/X11R6/lib -lXmu -lXm -lXt -lSM -lICE -lXext -lX11
-
- ifeq ($(MAKECMDGOALS),nogui)
--CFLAGS = -D NOGUI -I/usr/X11R6/include
--LIBS = -L/usr/lib -L/usr/X11R6/lib -lXmu -lXt -lSM -lICE -lXext -lX11
-+CFLAGS += -D NOGUI -I/usr/X11R6/include
-+LIBS = -L/usr/GENTOOLIBDIR -L/usr/X11R6/lib -lXmu -lXt -lSM -lICE -lXext -lX11
- endif
-
- FIN = -lm -pthread #for RH9.0, ok for RH7.3 & RH8.0
-@@ -26,13 +26,13 @@ OBJS = PKINANGL.o PKINCRTL.o PKINCSBS.o PKINCSUB.o PKINCOUT.o PKINMENU.o PKINROT
- # Commands specific to clients created by this Makefile
-
- prekin: $(OBJS)
-- cc -o prekin $(CFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
-+ cc -o prekin $(CFLAGS) $(LDFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
-
- debug: $(OBJS)
-- cc -o prekin $(CFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
-+ cc -o prekin $(CFLAGS) $(LDFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
-
- nogui: $(OBJS)
-- cc -o prekin $(CFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
-+ cc -o prekin $(CFLAGS) $(LDFLAGS) $(OBJS) -L/usr/X11R6/lib $(LIBS) -ldl $(FIN)
-
- clean:
- rm *.o
diff --git a/sci-chemistry/prekin/files/6.51.081122-overflow.patch b/sci-chemistry/prekin/files/6.51.081122-overflow.patch
deleted file mode 100644
index 1c6ded314315..000000000000
--- a/sci-chemistry/prekin/files/6.51.081122-overflow.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/PKIN.h
-+++ b/PKIN.h
-@@ -533,8 +533,8 @@ EXTERN float xnext,ynext,znext,onext,Bnext,Uvalnext;
- EXTERN char aspectstrnext[MAXaspects+3]; /*in parens: (XXXX)*/
-
- /* possible overlap with earlier PREKIN variables */
--EXTERN char word[256],texts[256],temps[256];
--EXTERN char alertstr[256],alertstr2[256],alertstr3[256];
-+EXTERN char word[256],texts[256],temps[512];
-+EXTERN char alertstr[1024],alertstr2[256],alertstr3[256];
- EXTERN char oldstr[256],olderstr[256],newstr[256],InfoStr[256],MolNameStr[16];
- EXTERN char NameStr[256],OutfileStr[256],ScriptinStr[256],ShortNameStr[256];
- EXTERN char DirStr[256],PDBfileStr[256],helpoutStr[256]; /*040425 helpout*/
-diff --git a/PKINCOUT.c b/PKINCOUT.c
-index af8eb24..a9f3a5f 100755
---- a/PKINCOUT.c
-+++ b/PKINCOUT.c
-@@ -17,7 +17,7 @@ static float VRMLx=0,VRMLy=0,VRMLz=0;
- void writeoutput()
- {
- char cntl[5]; /* 4 actual characters */
-- char kol[20],extra[256],aname[13];
-+ char kol[20],extra[256],aname[32];
- char chain[32],atoms[32],cpks[32],hygen[32],hbond[32];
- char subname[32],allstr[32];
- char mastername[32]; /*051128*/
diff --git a/sci-chemistry/prekin/files/prekin-6.51.081122-fno-common.patch b/sci-chemistry/prekin/files/prekin-6.51.081122-fno-common.patch
deleted file mode 100644
index 207d30152027..000000000000
--- a/sci-chemistry/prekin/files/prekin-6.51.081122-fno-common.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-https://bugs.gentoo.org/707310
---- a/PKININIT.c
-+++ b/PKININIT.c
-@@ -65,6 +65,8 @@ void writeversiontooutput(void); /*041011*/
- void writechangestooutput(void); /*040215*/
- void writecmdhelptooutput(void); /*040425*/
-
-+extern int Lribbonnew;
-+
- static char* prekinchanges[] =
- {"\r"
- ,"020514 Cbeta:Superpos,NB:Prekin,IOmage\r"
---- a/PKINRIBB.c
-+++ b/PKINRIBB.c
-@@ -6,6 +6,8 @@
- #define PKINRIBB
- #include "PKINRIBB.h"
- #undef PKINRIBB
-+
-+extern int Lribbonnew;
-
- /*{{{--NOTE-- version, etc. */
- /*051025 for now, just work with one model, and let prekin's levels==sections*/
---- a/PKINRIBB.h
-+++ b/PKINRIBB.h
-@@ -5,7 +5,7 @@
- #define PKINRIBB extern
- #endif
-
--PKINRIBB int Lribbonnew; /*051025 new ribbon structures: PKINRIBB*/
-+extern int Lribbonnew; /*051025 new ribbon structures: PKINRIBB*/
-
- #define CORDER 4 /*order of the B-spline defined here*/
-
diff --git a/sci-chemistry/prekin/metadata.xml b/sci-chemistry/prekin/metadata.xml
deleted file mode 100644
index 4ac68c154bb0..000000000000
--- a/sci-chemistry/prekin/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>sci-chemistry@gentoo.org</email>
- <name>Gentoo Chemistry Project</name>
-</maintainer>
-</pkgmetadata>
diff --git a/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild b/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild
deleted file mode 100644
index d6f5e98ced6b..000000000000
--- a/sci-chemistry/prekin/prekin-6.51.081122-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-MY_P=${PN}.${PV}
-DESCRIPTION="Prepares molecular kinemages from PDB-format coordinate files"
-HOMEPAGE="http://kinemage.biochem.duke.edu/software/prekin.php"
-SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${MY_P}.src.tgz"
-
-LICENSE="richardson"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="X"
-
-RDEPEND="
- x11-libs/libXext
- x11-libs/libXmu
- x11-libs/libXt
- x11-libs/libX11
- X? ( >=x11-libs/motif-2.3:0= )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-Makefile.patch
- "${FILESDIR}"/${PV}-overflow.patch
- "${FILESDIR}"/${P}-fno-common.patch
-)
-
-src_configure() {
- tc-export CC
-
- sed \
- -e 's:cc:$(CC):g' \
- -e "s:GENTOOLIBDIR:$(get_libdir):g" \
- Makefile.linux > Makefile || die
-}
-
-src_compile() {
- emake $(usex X ${PN} nogui)
-}
-
-src_install() {
- dobin prekin
-}