summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gelemental/files/gelemental-1.2.0-fix-c++14.patch14
-rw-r--r--sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild3
2 files changed, 16 insertions, 1 deletions
diff --git a/sci-chemistry/gelemental/files/gelemental-1.2.0-fix-c++14.patch b/sci-chemistry/gelemental/files/gelemental-1.2.0-fix-c++14.patch
new file mode 100644
index 000000000000..0965fe15b43e
--- /dev/null
+++ b/sci-chemistry/gelemental/files/gelemental-1.2.0-fix-c++14.patch
@@ -0,0 +1,14 @@
+Fix building with C++14, which errors out due to bool -> T* conversions
+See also: https://bugs.gentoo.org/show_bug.cgi?id=593994
+
+--- a/src/dialogs.cc
++++ b/src/dialogs.cc
+@@ -255,7 +255,7 @@
+ const Gtk::TreePath& tpath, bool)
+ {
+ Gtk::TreeIter iter = store->get_iter (tpath);
+- return iter ? iter->get_value (cols.property) : false;
++ return iter ? iter->get_value (cols.property) : NULL;
+ }
+
+
diff --git a/sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild b/sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild
index e85ddb0478b3..43e2cb8cb57d 100644
--- a/sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild
+++ b/sci-chemistry/gelemental/gelemental-1.2.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -40,6 +40,7 @@ PATCHES=(
"${WORKDIR}"/debian/patches/fix_zinc_german_translation.patch
"${WORKDIR}"/debian/patches/ftbfs_missing_limits.patch
"${WORKDIR}"/debian/patches/lp673285_link_in_about.patch
+ "${FILESDIR}"/${PN}-1.2.0-fix-c++14.patch
)
AUTOTOOLS_IN_SOURCE_BUILD=1