summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/dssp/Manifest1
-rw-r--r--sci-chemistry/dssp/dssp-4.4.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/Manifest b/sci-chemistry/dssp/Manifest
index 00d6647cdc54..3647716fcce1 100644
--- a/sci-chemistry/dssp/Manifest
+++ b/sci-chemistry/dssp/Manifest
@@ -2,3 +2,4 @@ DIST dssp-2.2.1.tgz 47141 BLAKE2B 34d8b2db8797a8c23763766c0214337f03584c4be52c1b
DIST dssp-3.0.11.tar.gz 168085 BLAKE2B e1c42fd22cfb2287f10b5deae48b56a4583d4a67737a3485dcbd160d1597a15c2d5105c3794c875d8001abede1c014efb4f7f5b7c250f867bdf9ed95a0860217 SHA512 a0cfe44e517ff1f909ef2928b62ae2c639c6bddfd8a0fb538883f647fd2771e00da68e0fd2521aa02ba3c6d1b0c9b784b7fe142392af3a3abf6ea89f1546bd9d
DIST dssp-4.2.2.1.tar.gz 144413 BLAKE2B 97c587bc0b4ef3d212ae81d568f817aab54f1dd2a77d170746e9b0d3f1bd63873d21fb0a7fc38c0300fc091f21241820d5d009d42a9e3e33dcc608c046185d9f SHA512 6daa41aea766940bf40afaee068daef341a7f79cae79d967b8da00e7002bdb602deaed40e452a5f0cea9aa2041a5c8678dfcae2e0f595cc5a0856392162dcdff
DIST dssp-4.3.1.tar.gz 226842 BLAKE2B 86318f05b8381d94fa9c65a956f5fb607ef8072b0395d912e20697ba36836c449ddff31a4a64d0005bbfe34899f71853c0f15a911042389fc894934c08fc34c8 SHA512 4dc1a3f5c7ba258ebf548674c7b33c36b0e3a7d14911394eb8d2955c235f3cb1d6c50cb03f411db55a8a9d7aa93e4d03354c47f9f0126b0bdcbf40dc9391d403
+DIST dssp-4.4.0.tar.gz 161773 BLAKE2B 87673be73f3163ba6fa090cc7acd4f864d41922033da9d126535b84e2da4defaaa8781a8cda6e80103dc75359718cd867b9baf90c74ae3ff923e212b520998a2 SHA512 1b09306c05587c278fcd881e0d3c169d44d960d8578f310adbd79b054683c257d0ee00d6bdfb5b0d7cd81c224f3572c2c7538a42d964817d587632128b96daa9
diff --git a/sci-chemistry/dssp/dssp-4.4.0.ebuild b/sci-chemistry/dssp/dssp-4.4.0.ebuild
new file mode 100644
index 000000000000..daf7c4f9314d
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-4.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/ https://github.com/PDB-REDO/dssp"
+SRC_URI="https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-libs/boost:=[zlib]
+ >=dev-libs/libmcfp-1.2.2
+ >=sci-libs/libcifpp-5.1.0
+"
+DEPEND=""
+RDEPEND="${BDEPEND}"
+
+src_configure() {
+ # gxrio not packaged
+ local mycmakeargs=(
+ -DBUILD_WEBSERVER=OFF
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if has_version "<=sci-chemistry/gromacs-2022"; then
+ ewarn "DSSP > 3.0.x is not compatible with gmx do_dssp:"
+ ewarn "https://gitlab.com/gromacs/gromacs/-/issues/4129"
+ ewarn
+ ewarn "Feel free to mask newer versions if needed."
+ fi
+}