summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/dssp/Manifest1
-rw-r--r--sci-chemistry/dssp/dssp-4.0.1_p20210831.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/Manifest b/sci-chemistry/dssp/Manifest
index ada8aac8e5c6..170fb6728d5e 100644
--- a/sci-chemistry/dssp/Manifest
+++ b/sci-chemistry/dssp/Manifest
@@ -1 +1,2 @@
DIST dssp-2.2.1.tgz 47141 BLAKE2B 34d8b2db8797a8c23763766c0214337f03584c4be52c1bc820a0df0db6a5f78ac0229aafdd47a60b8fd6f4832abf0399663c53f9e898c75f08ecbe22b141c8da SHA512 4a273714d6b3230daea166caa7f4117d5ccb225bea0cf1bc2eb61539b6cc8e227d0ba19047d61f0ad0d1d6bc2efdec9c193bd44341e15ef0950acb4a22498811
+DIST dssp-4.0.1_p20210831.tar.gz 121793 BLAKE2B 1e028b086b418772a93db350f8084d1786996ff6ea935d236b1431d8f4a07c0b33ebf374a4c4d5d4d243952f3f56e29a548ce09763863a1e0c529755fba6c211 SHA512 62f1ac781dd3d6f3436e6c155ae1a470d0baf6a6d9f6d6729034a7a5ef41550f76d0473c688d235279336306c9f3598377c056cddd6d00a89a826fbb04c1bfb3
diff --git a/sci-chemistry/dssp/dssp-4.0.1_p20210831.ebuild b/sci-chemistry/dssp/dssp-4.0.1_p20210831.ebuild
new file mode 100644
index 000000000000..407efe506226
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-4.0.1_p20210831.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/ https://github.com/PDB-REDO/dssp"
+
+COMMIT="728cc7c6c8d95460d8db453cf7adb25a89ba15f6"
+SRC_URI="https://github.com/PDB-REDO/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="
+ >=dev-libs/boost-1.70.0:=[threads(+)]
+ >=sci-libs/libcifpp-1.1.1
+"
+DEPEND=""
+RDEPEND="${BDEPEND}"
+
+pkg_postinst() {
+ if has_version sci-chemistry/gromacs; then
+ ewarn "DSSP > 3.0.x is not compatible with gmx do_dssp:"
+ ewarn "https://gitlab.com/gromacs/gromacs/-/issues/4129"
+ ewarn
+ ewarn "Feel free to mask newer versions if needed."
+ fi
+}