summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/MDAnalysis/MDAnalysis-2.0.0.ebuild37
-rw-r--r--sci-chemistry/MDAnalysis/Manifest1
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-chemistry/MDAnalysis/MDAnalysis-2.0.0.ebuild b/sci-chemistry/MDAnalysis/MDAnalysis-2.0.0.ebuild
new file mode 100644
index 000000000000..aee4e82b683e
--- /dev/null
+++ b/sci-chemistry/MDAnalysis/MDAnalysis-2.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python library to analyze and manipulate molecular dynamics trajectories"
+HOMEPAGE="https://www.mdanalysis.org"
+SRC_URI="mirror://pypi/M/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# TODO: fix this
+# ImportError: MDAnalysis not installed properly. This can happen if your C extensions have not been built.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.0.0[${PYTHON_USEDEP}]
+ >=sci-biology/biopython-1.71[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.0[${PYTHON_USEDEP}]
+ >=dev-python/GridDataFormats-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/joblib-0.12[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/mmtf-python-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/tqdm-4.43.0[${PYTHON_USEDEP}]
+ >=dev-python/gsd-1.9.3[${PYTHON_USEDEP}]
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests nose
diff --git a/sci-chemistry/MDAnalysis/Manifest b/sci-chemistry/MDAnalysis/Manifest
index 5a903a9f3b7f..721870b0e526 100644
--- a/sci-chemistry/MDAnalysis/Manifest
+++ b/sci-chemistry/MDAnalysis/Manifest
@@ -1 +1,2 @@
DIST MDAnalysis-1.0.0.tar.gz 19552874 BLAKE2B dab625a898d71a67a37ac5b58eb23ded9487f475e3c76f6c335a0ed5b32a43785d0473d089fcfc56c07263d82248bf5ee7b50c513441b10fc97f97b49411cc5f SHA512 4a001f45695308dd5f296bd2850d5d585c065e6b0f55efca65d91e452d78c85f13fd614eca0176a8d330e14a1c9e8ccbb919c3d4ae995b1945d09dc3ad687195
+DIST MDAnalysis-2.0.0.tar.gz 3436654 BLAKE2B b29734dd61bfa1e4e1d6ead0eb9a2d00869d1adce18edf95b9368bdcc16b0d71d0d6536a7df48787034a623bf52585e1636842dcaaa9dde08a69576868c1657b SHA512 037eb3c709b9ddbdb2ba9b26a6632ff99a95331c3968176573076e4e208c8644c3ea262e1e9880f185eb080ff90180d887444cab0dfbfad04fc254d87f1ff986