summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/kicad-templates/kicad-templates-7.0.9.ebuild')
-rw-r--r--sci-electronics/kicad-templates/kicad-templates-7.0.9.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-electronics/kicad-templates/kicad-templates-7.0.9.ebuild b/sci-electronics/kicad-templates/kicad-templates-7.0.9.ebuild
new file mode 100644
index 000000000000..bffd6445a28e
--- /dev/null
+++ b/sci-electronics/kicad-templates/kicad-templates-7.0.9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Electronic Schematic and PCB design tools project templates"
+HOMEPAGE="https://github.com/kicad/kicad-templates"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/libraries/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.com/kicad/libraries/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+
+RDEPEND=">=sci-electronics/kicad-7.0.0"