summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/puff/puff-20100127-r1.ebuild')
-rw-r--r--sci-electronics/puff/puff-20100127-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sci-electronics/puff/puff-20100127-r1.ebuild b/sci-electronics/puff/puff-20100127-r1.ebuild
index c13ddfb11313..1c89266a7936 100644
--- a/sci-electronics/puff/puff-20100127-r1.ebuild
+++ b/sci-electronics/puff/puff-20100127-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="microwave CAD software"
HOMEPAGE="https://wwwhome.cs.utwente.nl/~ptdeboer/ham/puff/"
@@ -22,13 +22,14 @@ src_prepare() {
# fix lib path for X11 and dont ignore LDFLAGS
sed -i -e "s#lib\\\/#$(get_libdir)\\\/#" \
-e 's/CFLAGS/#CFLAGS/' \
+ -e 's/CC =/#CC =/' \
-e 's/link.res/.res/g' \
-e 's/.res pu/.res $(LDFLAGS) pu/' Makefile || die
}
src_compile() {
LDFLAGS="$(raw-ldflags)"
- emake -j1
+ emake -j1 CC="$(tc-getCC)"
}
src_install() {