summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild')
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild
deleted file mode 100644
index 4ab5a682fe11..000000000000
--- a/sci-geosciences/geocode-glib/geocode-glib-3.18.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-GCONF_DEBUG="no" # --enable-debug does not do anything useful
-
-inherit gnome2
-
-DESCRIPTION="GLib geocoding library that uses the Yahoo! Place Finder service"
-HOMEPAGE="https://git.gnome.org/browse/geocode-glib"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="+introspection test"
-
-RDEPEND="
- >=dev-libs/glib-2.34:2
- >=dev-libs/json-glib-0.99.2[introspection?]
- gnome-base/gvfs[http]
- >=net-libs/libsoup-2.42:2.4[introspection?]
- introspection? (
- >=dev-libs/gobject-introspection-0.6.3:=
- net-libs/libsoup:2.4[introspection] )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.13
- >=sys-devel/gettext-0.18
- virtual/pkgconfig
- test? ( sys-apps/dbus )
-"
-# eautoreconf requires:
-# dev-libs/gobject-introspection-common
-# gnome-base/gnome-common
-
-# FIXME: need network #424719, recheck
-# need various locales to be present
-RESTRICT="test"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.18.1-fix-GLIBC-features.patch
-}
-
-src_configure() {
- gnome2_src_configure $(use_enable introspection)
-}
-
-src_test() {
- export GVFS_DISABLE_FUSE=1
- export GIO_USE_VFS=gvfs
- ewarn "Tests require network access to http://where.yahooapis.com"
- dbus-launch emake check || die "tests failed"
-}