summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/geocode-glib/geocode-glib-3.26.1.ebuild')
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.26.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.26.1.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.26.1.ebuild
new file mode 100644
index 000000000000..018bb7e4086a
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.26.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org meson xdg
+
+DESCRIPTION="GLib helper library for geocoding services"
+HOMEPAGE="https://git.gnome.org/browse/geocode-glib"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk-doc +introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.13
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/disable-installed-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test enable-installed-tests) # Actual installation to live system is sedded out, but we need this for running them in src_test
+ $(meson_use introspection enable-introspection)
+ $(meson_use gtk-doc enable-gtk-doc)
+ )
+ meson_src_configure
+}