summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild')
-rw-r--r--sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild b/sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild
index 0d45dcd66a4c..982684d854bb 100644
--- a/sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild
+++ b/sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop toolchain-funcs
+inherit desktop
DESCRIPTION="Tool for adjusting EXIF tags of your photos with a recorded GPS trace"
HOMEPAGE="https://dfandrich.github.io/gpscorrelate/"
@@ -28,12 +28,12 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-desktop-pass-validation.patch"
+ "${FILESDIR}/${P}-respect-users-flags.patch"
)
src_compile() {
- tc-export CC CXX PKG_CONFIG
- emake gpscorrelate CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
- use gtk && emake gpscorrelate-gui CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake gpscorrelate
+ use gtk && emake gpscorrelate-gui
}