summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild')
-rw-r--r--sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild b/sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild
new file mode 100644
index 000000000000..0d45dcd66a4c
--- /dev/null
+++ b/sci-geosciences/gpscorrelate/gpscorrelate-2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Tool for adjusting EXIF tags of your photos with a recorded GPS trace"
+HOMEPAGE="https://dfandrich.github.io/gpscorrelate/"
+SRC_URI="https://github.com/dfandrich/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="gtk"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/libxml2:2
+ media-gfx/exiv2:=
+ gtk? ( x11-libs/gtk+:3 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-desktop-pass-validation.patch"
+)
+
+src_compile() {
+ tc-export CC CXX PKG_CONFIG
+ emake gpscorrelate CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+ use gtk && emake gpscorrelate-gui CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+
+}
+
+src_install() {
+ dobin ${PN}
+ if use gtk; then
+ dobin ${PN}-gui
+ doicon -s scalable ${PN}-gui.svg
+ domenu ${PN}.desktop
+ fi
+ dodoc doc/*.html doc/*.png doc/*.xml
+ einstalldocs
+ doman doc/${PN}.1
+}